summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-01-24 00:50:22 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 00:50:22 +0100
commit66063cac9d1116295511b6af97b8ab106244c2b7 (patch)
treeacaaea972568318a52d13716b483eef07ea908b7 /dev-libs/ding-libs/ding-libs-0.6.1-r1.ebuild
parentmedia-libs/libbdplus: Minor style fixes, drop superfluous DOCS (diff)
downloadgentoo-66063cac9d1116295511b6af97b8ab106244c2b7.tar.gz
gentoo-66063cac9d1116295511b6af97b8ab106244c2b7.tar.bz2
gentoo-66063cac9d1116295511b6af97b8ab106244c2b7.zip
dev-libs/ding-libs: Port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/ding-libs/ding-libs-0.6.1-r1.ebuild')
-rw-r--r--dev-libs/ding-libs/ding-libs-0.6.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/ding-libs/ding-libs-0.6.1-r1.ebuild b/dev-libs/ding-libs/ding-libs-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..5ab407b043ee
--- /dev/null
+++ b/dev-libs/ding-libs/ding-libs-0.6.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="set of utility libraries (mostly used by sssd)"
+HOMEPAGE="https://pagure.io/SSSD/ding-libs"
+SRC_URI="https://releases.pagure.org/SSSD/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/0000-INI-Fix-detection-of-error-messages.patch
+ "${FILESDIR}"/0001-path_utils_ut-allow-single-as-well.patch
+ "${FILESDIR}"/0002-validators_ut_check-Fix-fail-with-new-glibc.patch
+)
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}