summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-07 09:21:17 +0000
committerSam James <sam@gentoo.org>2023-03-07 09:22:51 +0000
commit2b39ffb6bf88b5d0160a9c9b08a2409f0a7f2769 (patch)
tree26586762bf82fe301fef0bfe253d2e8a585c12e3 /dev-libs/distorm3
parentdev-python/pypugjs: enable py3.11 (diff)
downloadgentoo-2b39ffb6bf88b5d0160a9c9b08a2409f0a7f2769.tar.gz
gentoo-2b39ffb6bf88b5d0160a9c9b08a2409f0a7f2769.tar.bz2
gentoo-2b39ffb6bf88b5d0160a9c9b08a2409f0a7f2769.zip
dev-libs/distorm3: update EAPI 7 -> 8, enable py3.11, PEP517
Closes: https://github.com/mgorny/python-bump-testing/issues/43 Closes: https://bugs.gentoo.org/896700 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/distorm3')
-rw-r--r--dev-libs/distorm3/distorm3-3.5.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild b/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
new file mode 100644
index 000000000000..c623afc293d7
--- /dev/null
+++ b/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/yasm )"
+
+PATCHES=( "${FILESDIR}"/${P}-under.patch )
+
+EPYTEST_DESELECT=(
+ # outdated tests? API usage mismatch
+ # https://github.com/gdabah/distorm/issues/173
+ python/test_distorm3.py::Test::test_dummy
+ python/test_distorm3.py::InstBin::test_dummy
+ python/test_distorm3.py::Inst::test_dummy
+)
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}