summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-01-23 21:51:56 +0100
committerSebastian Pipping <sping@gentoo.org>2022-01-23 21:51:56 +0100
commit04a1b80c37a8f9964c67bd8aaa7dc9913d6c60ae (patch)
tree43fd23dcf8c43b9a442dfe70b07e266fe6f10492 /dev-libs/expat
parentwww-apps/trickster-1.1.5: build fixes (diff)
downloadgentoo-04a1b80c37a8f9964c67bd8aaa7dc9913d6c60ae.tar.gz
gentoo-04a1b80c37a8f9964c67bd8aaa7dc9913d6c60ae.tar.bz2
gentoo-04a1b80c37a8f9964c67bd8aaa7dc9913d6c60ae.zip
dev-libs/expat: Drop vulnerable
Bug: https://bugs.gentoo.org/830422 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/Manifest2
-rw-r--r--dev-libs/expat/expat-2.4.1.ebuild94
-rw-r--r--dev-libs/expat/expat-2.4.2.ebuild94
3 files changed, 0 insertions, 190 deletions
diff --git a/dev-libs/expat/Manifest b/dev-libs/expat/Manifest
index 945502be3827..6c2601c3fde7 100644
--- a/dev-libs/expat/Manifest
+++ b/dev-libs/expat/Manifest
@@ -1,3 +1 @@
-DIST expat-2.4.1.tar.xz 445024 BLAKE2B 2ae66d284a03176ef7290093f59bb7ad98011dfbf3c7c3515ba4e4b99f849474def6ce6d9844c944fed22d86ac4ea1a38863646be914d9432eda7b69d890be65 SHA512 9dc760dbf701f75e55c4479d81417622f8c750d8473498458a382a4c2932a2976a059cb3589f88855188e5173ec7868d285c4601428e0ca625df7a59cf975191
-DIST expat-2.4.2.tar.xz 449664 BLAKE2B 627ee86bd878b8f0edc50bdbeb26d347ec8bdd06fc369a3ee378ad133d38eb7cfe9018a5839843ba6757d727e84229c84c51d618b5de7e92197bdc7203e09b73 SHA512 c27f2b54e9babc6bd24283b62cc65546f37fa40481ac55b84d9e3ecad1b58d3c52055c71d56600b43aaf20ad142c70899a8dc424dba804b1699077c38dfe34a3
DIST expat-2.4.3.tar.xz 451012 BLAKE2B 4c0200837ea0054a88d2a2606486482f234e4b4f6b5f16134bf2a4b7b61457b12d534c6be3f16d28f6926f896d00177ef53a947a0a6c3ad11ff024a8e76edf84 SHA512 62a7fe751f6846deec4b04fd2c2ca8ed9e139fa27cda0e3fe7f8f05107caaed70597aed17b45c49d30a60c8a0c6beae1317dd5f24240640310951aabb16dbcb7
diff --git a/dev-libs/expat/expat-2.4.1.ebuild b/dev-libs/expat/expat-2.4.1.ebuild
deleted file mode 100644
index 8db61e9898d3..000000000000
--- a/dev-libs/expat/expat-2.4.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-AUTOTOOLS_AUTO_DEPEND=no
-AT_NOEAUTOHEADER=yes # because expat_config.h.in would need post-processing
-inherit autotools multilib-minimal
-
-DESCRIPTION="Stream-oriented XML parser library"
-HOMEPAGE="https://libexpat.github.io/"
-SRC_URI="https://github.com/libexpat/libexpat/releases/download/R_${PV//\./_}/expat-${PV}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="examples static-libs unicode"
-BDEPEND="unicode? ( ${AUTOTOOLS_DEPEND} )"
-
-DOCS=( README.md )
-
-src_prepare() {
- default
-
- # fix interpreter to be a recent/good shell
- sed -i -e "1s:/bin/sh:${BASH}:" conftools/get-version.sh || die
- if use unicode; then
- cp -R "${S}" "${S}"w || die
- pushd "${S}"w >/dev/null
- find -name Makefile.am \
- -exec sed \
- -e 's,libexpat\.la,libexpatw.la,' \
- -e 's,libexpat_la,libexpatw_la,' \
- -i {} + || die
- eautoreconf
- popd >/dev/null
- fi
-}
-
-multilib_src_configure() {
- local myconf="$(use_enable static-libs static) --without-docbook"
-
- mkdir -p "${BUILD_DIR}"w || die
-
- if use unicode; then
- pushd "${BUILD_DIR}"w >/dev/null
- CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}"w econf ${myconf}
- popd >/dev/null
- fi
-
- ECONF_SOURCE="${S}" econf ${myconf}
-}
-
-multilib_src_compile() {
- emake
-
- if use unicode; then
- pushd "${BUILD_DIR}"w >/dev/null
- emake -C lib
- popd >/dev/null
- fi
-}
-
-multilib_src_install() {
- emake install DESTDIR="${D}"
-
- if use unicode; then
- pushd "${BUILD_DIR}"w >/dev/null
- emake -C lib install DESTDIR="${D}"
- popd >/dev/null
-
- pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
- cp expat.pc expatw.pc
- sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
- popd >/dev/null
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- doman doc/xmlwf.1
-
- # Note: Use of HTML_DOCS would add unwanted "doc" subfolder
- docinto html
- dodoc doc/*.{css,html}
-
- if use examples; then
- docinto examples
- dodoc examples/*.c
- docompress -x usr/share/doc/${PF}/examples
- fi
-
- find "${D}" -name '*.la' -type f -delete || die
-}
diff --git a/dev-libs/expat/expat-2.4.2.ebuild b/dev-libs/expat/expat-2.4.2.ebuild
deleted file mode 100644
index f397e99485c2..000000000000
--- a/dev-libs/expat/expat-2.4.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-AUTOTOOLS_AUTO_DEPEND=no
-AT_NOEAUTOHEADER=yes # because expat_config.h.in would need post-processing
-inherit autotools multilib-minimal
-
-DESCRIPTION="Stream-oriented XML parser library"
-HOMEPAGE="https://libexpat.github.io/"
-SRC_URI="https://github.com/libexpat/libexpat/releases/download/R_${PV//\./_}/expat-${PV}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="examples static-libs unicode"
-BDEPEND="unicode? ( ${AUTOTOOLS_DEPEND} )"
-
-DOCS=( README.md )
-
-src_prepare() {
- default
-
- # fix interpreter to be a recent/good shell
- sed -i -e "1s:/bin/sh:${BASH}:" conftools/get-version.sh || die
- if use unicode; then
- cp -R "${S}" "${S}"w || die
- pushd "${S}"w >/dev/null
- find -name Makefile.am \
- -exec sed \
- -e 's,libexpat\.la,libexpatw.la,' \
- -e 's,libexpat_la,libexpatw_la,' \
- -i {} + || die
- eautoreconf
- popd >/dev/null
- fi
-}
-
-multilib_src_configure() {
- local myconf="$(use_enable static-libs static) --without-docbook"
-
- mkdir -p "${BUILD_DIR}"w || die
-
- if use unicode; then
- pushd "${BUILD_DIR}"w >/dev/null
- CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}"w econf ${myconf}
- popd >/dev/null
- fi
-
- ECONF_SOURCE="${S}" econf ${myconf}
-}
-
-multilib_src_compile() {
- emake
-
- if use unicode; then
- pushd "${BUILD_DIR}"w >/dev/null
- emake -C lib
- popd >/dev/null
- fi
-}
-
-multilib_src_install() {
- emake install DESTDIR="${D}"
-
- if use unicode; then
- pushd "${BUILD_DIR}"w >/dev/null
- emake -C lib install DESTDIR="${D}"
- popd >/dev/null
-
- pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
- cp expat.pc expatw.pc
- sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
- popd >/dev/null
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- doman doc/xmlwf.1
-
- # Note: Use of HTML_DOCS would add unwanted "doc" subfolder
- docinto html
- dodoc doc/*.{css,html}
-
- if use examples; then
- docinto examples
- dodoc examples/*.c
- docompress -x usr/share/doc/${PF}/examples
- fi
-
- find "${D}" -name '*.la' -type f -delete || die
-}