summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-28 12:06:11 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-28 14:14:24 -0700
commitc2dbfe4ac6c9beda86f739795ee47e834be0f5bc (patch)
treee636c4efef09da117c6c2efa1ac6ba80895bdbd1 /dev-libs/gdl
parentapp-text/iso-codes: Version bump to 4.7.0 (diff)
downloadgentoo-c2dbfe4ac6c9beda86f739795ee47e834be0f5bc.tar.gz
gentoo-c2dbfe4ac6c9beda86f739795ee47e834be0f5bc.tar.bz2
gentoo-c2dbfe4ac6c9beda86f739795ee47e834be0f5bc.zip
dev-libs/gdl: Version bump to 3.40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gdl')
-rw-r--r--dev-libs/gdl/Manifest1
-rw-r--r--dev-libs/gdl/gdl-3.40.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/gdl/Manifest b/dev-libs/gdl/Manifest
index e8ea40fe0eea..aabccc171411 100644
--- a/dev-libs/gdl/Manifest
+++ b/dev-libs/gdl/Manifest
@@ -1 +1,2 @@
DIST gdl-3.34.0.tar.xz 531368 BLAKE2B 5e32c330ab2fda0b9f06de0fd9d7e3f3118b0af36a73f4f0280f069b49002a4d00e5cbfd373d65b0ea7a15bb5b577f8babbdf7ee71ed7db773d2ad65008a452e SHA512 8c43f330556dae67e4f64e92c3ba5c2e9351d3040d6002bda89f20f9494fc93030abe80072f0cf86280f98e290805154e9ca12aaa7013f0a341d8ea94323d3b0
+DIST gdl-3.40.0.tar.xz 534016 BLAKE2B d403da4040053ce81352e14d538d15a5331423c3bb2aa76f38f4da8ccea22790507ca21fc8e6246e29dae1aa4297ecf470a71a0862475e7767a7fe7c03c8d5f4 SHA512 38cf787a47e7eece445c7bf321cb5aa691cc6bdfcb31bc10fb51c83c525b74fc8374a20989621d79e70f25ef92d9d7cce46f6f0bb993cceba3fb93b9092c1e32
diff --git a/dev-libs/gdl/gdl-3.40.0.ebuild b/dev-libs/gdl/gdl-3.40.0.ebuild
new file mode 100644
index 000000000000..2761698684bc
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.40.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gdl"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+"
+BDEPEND="
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-gtk-doc
+}