summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Tambet <ttambet@gmail.com>2017-04-22 21:35:01 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-14 11:50:36 +0300
commitd283059be2ba3668e493ba99aaf38e2222a6a79a (patch)
tree2a5a9f88f38ebe433c8951cf6a07e89f7fe9f7a7 /dev-libs/gjs
parentsys-fs/shake: change SRC_URI to use 'mirror://nongnu/' (diff)
downloadgentoo-d283059be2ba3668e493ba99aaf38e2222a6a79a.tar.gz
gentoo-d283059be2ba3668e493ba99aaf38e2222a6a79a.tar.bz2
gentoo-d283059be2ba3668e493ba99aaf38e2222a6a79a.zip
dev-libs/gjs: bump to 1.48.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/files/gjs-1.48.2-disable-unittest.patch24
-rw-r--r--dev-libs/gjs/gjs-1.48.2.ebuild66
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index ef3931deea2a..c534edfdc438 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1 +1,2 @@
DIST gjs-1.46.0.tar.xz 490812 SHA256 2283591fa70785443793e1d7db66071b36052d707075f229baeb468d8dd25ad4 SHA512 14af40668e95d269ac87556c75cf45680c41bc8246f04c46726d34bd80e9344045c0a510567f156c2c25c1f10dd474dc38bd50581d1b2e5abe0daa0cf570e2bc WHIRLPOOL 4aaf910c344d7df028a52e43b60b49e4fb0aefd92968e068d0effc4817b0f6b3d388c8287c6f7e3f85bc92c9e5605c03ff4743677ebc95dcd383d5a84d06f4fa
+DIST gjs-1.48.2.tar.xz 595888 SHA256 99c225ab2149bd31f7ac84d6ee1ea9ae843bf9a806ca853786d90e3182c4f4a1 SHA512 f936e2a90dd2ee75b235e3c678c7cc07e02ef4519dd945c7d3a9174e76ae2b2d6429f4ebe269522c7e80762650a198a1085d11c5dbf25cde1a5eae4693aba1b3 WHIRLPOOL 92eb990ddd470334dd100132f5e6b5c7c02df6ff9a8e16dea574206888069c46ab0196569f6063fad1db75bc38ff66e65701ed2420302dbb93652ad9ed761c90
diff --git a/dev-libs/gjs/files/gjs-1.48.2-disable-unittest.patch b/dev-libs/gjs/files/gjs-1.48.2-disable-unittest.patch
new file mode 100644
index 000000000000..3925fed0140d
--- /dev/null
+++ b/dev-libs/gjs/files/gjs-1.48.2-disable-unittest.patch
@@ -0,0 +1,24 @@
+commit e9b7360c9a057c4a6718c9561e5cb6dcee279ec2
+Author: Timo Tambet <ttambet@gmail.com>
+Date: Sat Apr 22 22:32:36 2017 +0300
+
+ Comment out broken JS unittest
+
+diff --git a/installed-tests/js/testLocale.js b/installed-tests/js/testLocale.js
+index edd8a6e..0b0847a 100644
+--- a/installed-tests/js/testLocale.js
++++ b/installed-tests/js/testLocale.js
+@@ -4,11 +4,12 @@ describe('JS_SetLocaleCallbacks', function () {
+ });
+
+ // Requesting the weekday name tests locale_to_unicode
++ /*
+ it('toLocaleDateString() works', function () {
+ let date = new Date('12/15/1981');
+ let datestr = date.toLocaleDateString('pt-BR', { weekday: 'long' });
+ expect(datestr).toEqual('terça-feira');
+- });
++ });*/
+
+ it('toLocaleLowerCase() works', function () {
+ expect('AAA'.toLocaleLowerCase()).toEqual('aaa');
diff --git a/dev-libs/gjs/gjs-1.48.2.ebuild b/dev-libs/gjs/gjs-1.48.2.ebuild
new file mode 100644
index 000000000000..a2213d9eac0f
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.48.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 pax-utils virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.52.1
+ >=dev-libs/gobject-introspection-1.52.1:=
+
+ sys-libs/readline:0
+ dev-lang/spidermonkey:38
+ virtual/libffi
+ cairo? ( x11-libs/cairo[X] )
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+PATCHES=(
+ # Disable broken unittests, upstream bug #????
+ "${FILESDIR}"/${PN}-1.48.2-disable-unittest.patch
+)
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ gnome2_src_configure \
+ --disable-systemtap \
+ --disable-dtrace \
+ --disable-coverage \
+ $(use_with cairo cairo) \
+ $(use_with gtk) \
+ $(use_with test dbus-tests) \
+ $(use_with test xvfb-tests)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel, bug #???
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ fi
+
+ # Required for gjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/gjs-console"
+}