summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-01 12:32:57 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-01 12:32:57 +0100
commit4f28ec5225e82612bbdd85dbd82d8a2908bb4186 (patch)
tree9f58a7a70c1db4fce9d0679c17ecd15c3858c336 /dev-libs/gmime
parentmedia-sound/schismtracker: dropped obsolete 20220905 (diff)
downloadgentoo-4f28ec5225e82612bbdd85dbd82d8a2908bb4186.tar.gz
gentoo-4f28ec5225e82612bbdd85dbd82d8a2908bb4186.tar.bz2
gentoo-4f28ec5225e82612bbdd85dbd82d8a2908bb4186.zip
dev-libs/gmime: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/gmime-2.6.23-r2.ebuild (renamed from dev-libs/gmime/gmime-2.6.23-r1.ebuild)42
1 files changed, 16 insertions, 26 deletions
diff --git a/dev-libs/gmime/gmime-2.6.23-r1.ebuild b/dev-libs/gmime/gmime-2.6.23-r2.ebuild
index cbeaa7bf8361..4bf6d80f39bf 100644
--- a/dev-libs/gmime/gmime-2.6.23-r1.ebuild
+++ b/dev-libs/gmime/gmime-2.6.23-r2.ebuild
@@ -1,65 +1,55 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-VALA_USE_DEPEND="vapigen"
+EAPI=8
-inherit gnome2 vala flag-o-matic
+VALA_USE_DEPEND="vapigen"
+inherit flag-o-matic gnome2 vala
DESCRIPTION="Library for creating and parsing MIME messages"
HOMEPAGE="http://spruce.sourceforge.net/gmime/"
-SLOT="2.6"
LICENSE="LGPL-2.1"
+SLOT="2.6"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="doc smime static-libs test vala"
+IUSE="doc smime test vala"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-libs/glib-2.32.0:2
+ dev-libs/glib:2
sys-libs/zlib
smime? ( >=app-crypt/gpgme-1.1.6:= )
- vala? (
- $(vala_depend)
- >=dev-libs/gobject-introspection-1.30.0:= )
+ vala? ( >=dev-libs/gobject-introspection-1.30.0:= )
"
DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.8
virtual/libiconv
+"
+BDEPEND="
+ >=dev-util/gtk-doc-am-1.8
virtual/pkgconfig
doc? ( app-text/docbook-sgml-utils )
test? ( app-crypt/gnupg )
+ vala? ( $(vala_depend) )
"
# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally
-src_prepare() {
- gnome2_src_prepare
- use vala && vala_src_prepare
-}
-
src_configure() {
+ use vala && vala_setup
+
[[ ${CHOST} == *-solaris* ]] && append-libs iconv
gnome2_src_configure \
--enable-cryptography \
--disable-strict-parser \
--disable-mono \
$(use_enable smime) \
- $(use_enable static-libs static) \
$(use_enable vala)
}
src_compile() {
gnome2_src_compile
+
if use doc; then
emake -C docs/tutorial html
- fi
-}
-
-src_install() {
- gnome2_src_install
-
- if use doc ; then
- docinto tutorial
- dodoc -r docs/tutorial/html/
+ HTML_DOCS=( docs/tutorial/html/. )
fi
}