summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-08-28 12:08:41 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-08-28 12:24:56 +0200
commite4338840d337ed7b7a80408cde81194b6e555bde (patch)
treeb7d97bb43720ee542b892c47d20e3b2340f3b01d /dev-libs/hidapi
parentdev-libs/hidapi: add myself as a maintainer (diff)
downloadgentoo-e4338840d337ed7b7a80408cde81194b6e555bde.tar.gz
gentoo-e4338840d337ed7b7a80408cde81194b6e555bde.tar.bz2
gentoo-e4338840d337ed7b7a80408cde81194b6e555bde.zip
dev-libs/hidapi: add 0.12.0
Closes: https://bugs.gentoo.org/696482 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'dev-libs/hidapi')
-rw-r--r--dev-libs/hidapi/Manifest1
-rw-r--r--dev-libs/hidapi/hidapi-0.12.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/hidapi/Manifest b/dev-libs/hidapi/Manifest
index 6de08b4220b1..51ef78834f84 100644
--- a/dev-libs/hidapi/Manifest
+++ b/dev-libs/hidapi/Manifest
@@ -1,2 +1,3 @@
DIST hidapi-0.11.0.tgz 232631 BLAKE2B 770c0663b007aa36580af217d0d38be72923e0ad84cee137594ca3e174e589cebb9188003a50999e1c561b0e4e9ca68bd1af29029b89fde2b0a46020b12f9744 SHA512 0de4abc963600d159ce231416c468b9e81a8361e4d2c2202988d6eb2e58a923700e9b9be639fbddc6bc14625131848409e2e88dbc4b34a1f8a726c8fa4692d92
+DIST hidapi-0.12.0.tgz 238751 BLAKE2B 25eddf337970275a026839dfe8c0c3beef58da892a6b192751f70faa7ca3ad12f9deab34c3800e053ef9bdefca481a863fac0c25aab51dbf172b44bd94e34e56 SHA512 866268927698db6fa553e000ead3c0c4b8df67ea768d36acac9c71f06f0bd8283778e90eee03f81aaa930f38dbb5719391906c7d2742b74479ffa436104f5fa4
DIST hidapi-0.8.0_rc1_p20140719.tgz 103079 BLAKE2B f40a4c17cb8c5eed41f4eea84fac46a879ec2057f28212aa43c8fd718ceea68d760785cb4f4e2ea3bcd2a4345b65d75d0d278b93697ec61963be9270684a15cb SHA512 204934a707da4e67b834823650b0cfd9be7b413972071129cc5aeeb93465834dde2f5ee23283c55d35b56e3aed8b7ad5fe947399839081f4d895fb65c8cd3e3d
diff --git a/dev-libs/hidapi/hidapi-0.12.0.ebuild b/dev-libs/hidapi/hidapi-0.12.0.ebuild
new file mode 100644
index 000000000000..8985fb90147a
--- /dev/null
+++ b/dev-libs/hidapi/hidapi-0.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
+HOMEPAGE="https://github.com/libusb/hidapi"
+SRC_URI="https://github.com/libusb/hidapi/archive/${P}.tar.gz -> ${P}.tgz"
+
+LICENSE="|| ( BSD GPL-3 HIDAPI )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ virtual/libusb:1[${MULTILIB_USEDEP}]
+ virtual/libudev:0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if use doc && multilib_is_native_abi; then
+ doxygen "${S}/doxygen/Doxyfile" || die
+ fi
+}
+
+multilib_src_install() {
+ cmake_src_install
+
+ if use doc && multilib_is_native_abi; then
+ local HTML_DOCS=( html/. )
+ fi
+ einstalldocs
+}