summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-27 10:07:36 +0000
committerSam James <sam@gentoo.org>2024-01-27 10:20:05 +0000
commit2dd3a8d117228f575688a0c862b0eb72a68cb9f9 (patch)
tree1ccb2c68824ae6da9d9456ca1e58693720f0c73a /dev-libs/inih/inih-58.ebuild
parentdev-libs/inih: drop 56-r1, 57 (diff)
downloadgentoo-2dd3a8d117228f575688a0c862b0eb72a68cb9f9.tar.gz
gentoo-2dd3a8d117228f575688a0c862b0eb72a68cb9f9.tar.bz2
gentoo-2dd3a8d117228f575688a0c862b0eb72a68cb9f9.zip
dev-libs/inih: add 58
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/inih/inih-58.ebuild')
-rw-r--r--dev-libs/inih/inih-58.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/inih/inih-58.ebuild b/dev-libs/inih/inih-58.ebuild
new file mode 100644
index 000000000000..6793c8255fc4
--- /dev/null
+++ b/dev-libs/inih/inih-58.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests not wired up to meson and don't seem to be intended for downstream use yet
+# e.g. hardcoding gcc, just a shell script
+
+inherit meson-multilib
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/inih-r${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DOCS=( README.md )
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson-multilib_src_configure
+}