summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Zero <zero-one@zer0-one.net>2020-12-06 01:25:50 -0800
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:44:21 +0200
commit0b4171655437ff84b5b03a5763a42a764578cd4b (patch)
treea7b91c9dd648bbf146b664631ea8881b8ebdb9a0 /dev-libs/jansson/jansson-2.13.1-r1.ebuild
parentdev-python/pybtex: fix 0.23.0 to default skel format (diff)
downloadgentoo-0b4171655437ff84b5b03a5763a42a764578cd4b.tar.gz
gentoo-0b4171655437ff84b5b03a5763a42a764578cd4b.tar.bz2
gentoo-0b4171655437ff84b5b03a5763a42a764578cd4b.zip
dev-libs/jansson: remove dependency on sphinx < 3.0
This revision removes the dependency on sphinx < 3.0 . Closes: https://bugs.gentoo.org/731668 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Zero <zero-one@zer0-one.net> Closes: https://github.com/gentoo/gentoo/pull/18528 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/jansson/jansson-2.13.1-r1.ebuild')
-rw-r--r--dev-libs/jansson/jansson-2.13.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/jansson/jansson-2.13.1-r1.ebuild b/dev-libs/jansson/jansson-2.13.1-r1.ebuild
new file mode 100644
index 000000000000..1f926f3cbf18
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.13.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="https://www.digip.org/jansson/"
+SRC_URI="https://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-macos"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+PATCHES=(
+ # dev-libs/jansson-2.13.1[doc]: fails to build with >=sphinx-3.0, #731668
+ "${FILESDIR}/${P}-sphinx3.patch"
+)
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}