summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-01 03:54:17 +0000
committerSam James <sam@gentoo.org>2024-03-01 03:54:17 +0000
commitaed53bca3e473c593159ee31f1b98ce68a45b85a (patch)
tree02ef493a7dc75db5cf1f94cea321457a422ec1fa /dev-libs/keystone
parentapp-crypt/mit-krb5: filter LTO (diff)
downloadgentoo-aed53bca3e473c593159ee31f1b98ce68a45b85a.tar.gz
gentoo-aed53bca3e473c593159ee31f1b98ce68a45b85a.tar.bz2
gentoo-aed53bca3e473c593159ee31f1b98ce68a45b85a.zip
dev-libs/keystone: filter LTO (ODR violations)
The ODR violations are in a bundled copy of LLVM and upstream seems to have low activity, and no release in 4 years. Closes: https://bugs.gentoo.org/924866 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/keystone')
-rw-r--r--dev-libs/keystone/keystone-0.9.2-r3.ebuild5
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/keystone/keystone-0.9.2-r3.ebuild b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
index bfc2d7d6fa78..0edae53eacbe 100644
--- a/dev-libs/keystone/keystone-0.9.2-r3.ebuild
+++ b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
@@ -8,7 +8,7 @@ DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake distutils-r1
+inherit cmake distutils-r1 flag-o-matic
DESCRIPTION="assembly/assembler framework + bindings"
HOMEPAGE="https://www.keystone-engine.org/"
@@ -75,6 +75,9 @@ src_prepare() {
}
src_configure() {
+ # ODR violations in bundled LLVM (bug #924866)
+ filter-lto
+
local libdir="$(get_libdir)"
local mycmakeargs=(
-DCMAKE_CONFIGURATION_TYPES="Gentoo"
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
index 8d3497ec3aed..c1e7b73fa5d4 100644
--- a/dev-libs/keystone/keystone-9999.ebuild
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -8,7 +8,7 @@ DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake distutils-r1
+inherit cmake distutils-r1 flag-o-matic
DESCRIPTION="assembly/assembler framework + bindings"
HOMEPAGE="https://www.keystone-engine.org/"
@@ -71,6 +71,9 @@ src_prepare() {
}
src_configure() {
+ # ODR violations in bundled LLVM (bug #924866)
+ filter-lto
+
local libdir="$(get_libdir)"
local mycmakeargs=(
-DCMAKE_CONFIGURATION_TYPES="Gentoo"