summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-19 12:53:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-19 13:01:01 +0200
commit69a84a90ab9845e2f5aff9a82d794a1161ac1328 (patch)
tree0e36cbb999931191cc6b4517dc1310ec08443930 /dev-libs/libbsd
parentsys-apps/ipmiutil: Removed old (diff)
downloadgentoo-69a84a90ab9845e2f5aff9a82d794a1161ac1328.tar.gz
gentoo-69a84a90ab9845e2f5aff9a82d794a1161ac1328.tar.bz2
gentoo-69a84a90ab9845e2f5aff9a82d794a1161ac1328.zip
dev-libs/libbsd: Bump to version 0.10.0
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.10.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 0979330cdd41..51746ae46128 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1,3 +1,4 @@
+DIST libbsd-0.10.0.tar.xz 393576 BLAKE2B 66005a511dae7fb799322c813b8ea058ab460e3b9044756d6efad5de741d8f70270496f09803bbce8cd0000ff37e998f18e092037c850826c3c8e3f47ddfdb28 SHA512 b75529785b16c93d31401187f8a58258fbebe565dac071c8311775c913af989f62cd29d5ce2651af3ea6221cffd31cf04826577d3e546ab9ca14340f297777b9
DIST libbsd-0.8.6.tar.xz 371112 BLAKE2B adab6c17267e0cff128351efccf5c1225b7dd85dc61dd8168bf212ba5aff8d726fa5be687c041821af9a427ddad9dfcd3630cac9134b9e81c86ab2599e43aef9 SHA512 ece01ced324f840c2cee6321c7dcf97ff123d55ea9f203c1ce35e1b46643dc7b34ef6dc6c8d128252b36848624850b40823411cc96b99a66a401eb1e9d8cea6b
DIST libbsd-0.8.7.tar.xz 371772 BLAKE2B aa4aa1c19872edf9e7e6ed270275199366345531a48ee28c25e209f17c5403a22269b91ab1c806cb1b54ba33a8464f4b035fe7ee2bc5dddd0a4fda09c540b058 SHA512 605a14eb5d33c0e45c3bd29e585ebc15832e2ed1efa9356291a0562622168da96db1a20766e9dae8910ea0c1516429f43905edc8d4f2a40a5a341a689d08fcc3
DIST libbsd-0.9.1.tar.xz 387180 BLAKE2B 40dd82ca1088ee7aae8b3d7685e8514eec702bf7ada7ef98f7177cad92b7e0fccc22a953b35f0f27202eb56833b31a81bef1324d43864d1b80887ba7c58684d5 SHA512 435822b8f2495a5e2705e5ab5c834a4f0f3a177b3e5c46a7c6162924507ca984e957e94a512b5ebd0067ecb413bac458fade357709ef199e9b75edf0315de91c
diff --git a/dev-libs/libbsd/libbsd-0.10.0.ebuild b/dev-libs/libbsd/libbsd-0.10.0.ebuild
new file mode 100644
index 000000000000..383f350fac24
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-3.17"
+RDEPEND=""
+
+pkg_setup() {
+ local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://gitlab.freedesktop.org/libbsd/libbsd/commit/c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ find "${ED}" -type f -name "*.la" -delete || die
+}