summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libgit2-glib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libgit2-glib/files')
-rw-r--r--dev-libs/libgit2-glib/files/libgit2-glib-0.0.24-automagic-ssh.patch75
-rw-r--r--dev-libs/libgit2-glib/files/libgit2-glib-0.22.0-automagic-ssh.patch93
2 files changed, 168 insertions, 0 deletions
diff --git a/dev-libs/libgit2-glib/files/libgit2-glib-0.0.24-automagic-ssh.patch b/dev-libs/libgit2-glib/files/libgit2-glib-0.0.24-automagic-ssh.patch
new file mode 100644
index 000000000000..5c3904cc0062
--- /dev/null
+++ b/dev-libs/libgit2-glib/files/libgit2-glib-0.0.24-automagic-ssh.patch
@@ -0,0 +1,75 @@
+diff --git a/configure.ac b/configure.ac
+index 8c1559c..94175c9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,32 +79,44 @@ dnl ===========================================================================
+ dnl Check for libgit2 ssh support
+ dnl ===========================================================================
+
+-AC_MSG_CHECKING([for libgit2 ssh support])
+-
+-cflags_save="${CFLAGS}"
+-libs_save="${LIBS}"
+-
+-CFLAGS="${LIBGIT2_GLIB_CFLAGS}"
+-LIBS="${LIBGIT2_GLIB_LIBS}"
+-
+-AC_TRY_RUN([
+- #include <git2.h>
+- int
+- main(int argc, const char *argv[])
+- {
+- git_threads_init ();
+- return ((git_libgit2_features() & GIT_FEATURE_SSH) != 0) ? 0 : 1;
+- }
+-],[
+- AC_MSG_RESULT([yes])
+- git_ssh=yes
+-],[
+- AC_MSG_RESULT([no])
+- git_ssh=no
+-])
+-
+-CFLAGS="${cflags_save}"
+-LIBS="${libs_save}"
++AC_ARG_ENABLE([ssh],
++ AS_HELP_STRING([--enable-ssh[=@<:@no/auto/yes@:>@]],[Build with libgit2 ssh support]),
++ [enable_ssh=$enableval],
++ [enable_ssh="auto"])
++
++git_ssh=no
++
++if test "x$enable_ssh" != "xno"; then
++ AC_MSG_CHECKING([for libgit2 ssh support])
++
++ cflags_save="${CFLAGS}"
++ libs_save="${LIBS}"
++
++ CFLAGS="${LIBGIT2_GLIB_CFLAGS}"
++ LIBS="${LIBGIT2_GLIB_LIBS}"
++
++ AC_TRY_RUN([
++ #include <git2.h>
++ int
++ main(int argc, const char *argv[])
++ {
++ git_threads_init ();
++ return ((git_libgit2_features() & GIT_FEATURE_SSH) != 0) ? 0 : 1;
++ }
++ ],[
++ AC_MSG_RESULT([yes])
++ git_ssh=yes
++ ],[
++ AC_MSG_RESULT([no])
++ git_ssh=no
++ if test "x$enable_ssh" = "xyes"; then
++ AC_MSG_ERROR([libgit2 ssh support was requiested, but not found])
++ fi
++ ])
++
++ CFLAGS="${cflags_save}"
++ LIBS="${libs_save}"
++fi
+
+ if test "x$git_ssh" = "xyes"; then
+ LIBGIT2_GLIB_CFLAGS="${LIBGIT2_GLIB_CFLAGS} -DGIT_SSH=1"
diff --git a/dev-libs/libgit2-glib/files/libgit2-glib-0.22.0-automagic-ssh.patch b/dev-libs/libgit2-glib/files/libgit2-glib-0.22.0-automagic-ssh.patch
new file mode 100644
index 000000000000..9ec626486f66
--- /dev/null
+++ b/dev-libs/libgit2-glib/files/libgit2-glib-0.22.0-automagic-ssh.patch
@@ -0,0 +1,93 @@
+From e67a9ba456bc7f4b6b8c4899179d6b7a2863d592 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Tue, 20 Jan 2015 08:12:41 +0100
+Subject: [PATCH] configure: Add flag to force on or off SSH support
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Remove an automagic dependency on libgit2's SSH support.
+
+Signed-off-by: Rémi Cardona <remi@gentoo.org>
+---
+ configure.ac | 64 ++++++++++++++++++++++++++++++++++++------------------------
+ 1 file changed, 38 insertions(+), 26 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1bd96bc..61744db 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,32 +79,44 @@ dnl ===========================================================================
+ dnl Check for libgit2 ssh support
+ dnl ===========================================================================
+
+-AC_MSG_CHECKING([for libgit2 ssh support])
+-
+-cflags_save="${CFLAGS}"
+-libs_save="${LIBS}"
+-
+-CFLAGS="${LIBGIT2_GLIB_CFLAGS}"
+-LIBS="${LIBGIT2_GLIB_LIBS}"
+-
+-AC_TRY_RUN([
+- #include <git2.h>
+- int
+- main(int argc, const char *argv[])
+- {
+- git_libgit2_init ();
+- return ((git_libgit2_features() & GIT_FEATURE_SSH) != 0) ? 0 : 1;
+- }
+-],[
+- AC_MSG_RESULT([yes])
+- git_ssh=yes
+-],[
+- AC_MSG_RESULT([no])
+- git_ssh=no
+-])
+-
+-CFLAGS="${cflags_save}"
+-LIBS="${libs_save}"
++AC_ARG_ENABLE([ssh],
++ AS_HELP_STRING([--enable-ssh[=@<:@no/auto/yes@:>@]],[Build with libgit2 ssh support]),
++ [enable_ssh=$enableval],
++ [enable_ssh="auto"])
++
++git_ssh=no
++
++if test "x$enable_ssh" != "xno"; then
++ AC_MSG_CHECKING([for libgit2 ssh support])
++
++ cflags_save="${CFLAGS}"
++ libs_save="${LIBS}"
++
++ CFLAGS="${LIBGIT2_GLIB_CFLAGS}"
++ LIBS="${LIBGIT2_GLIB_LIBS}"
++
++ AC_TRY_RUN([
++ #include <git2.h>
++ int
++ main(int argc, const char *argv[])
++ {
++ git_libgit2_init ();
++ return ((git_libgit2_features() & GIT_FEATURE_SSH) != 0) ? 0 : 1;
++ }
++ ],[
++ AC_MSG_RESULT([yes])
++ git_ssh=yes
++ ],[
++ AC_MSG_RESULT([no])
++ git_ssh=no
++ if test "x$enable_ssh" = "xyes"; then
++ AC_MSG_ERROR([libgit2 ssh support was requiested, but not found])
++ fi
++ ])
++
++ CFLAGS="${cflags_save}"
++ LIBS="${libs_save}"
++fi
+
+ if test "x$git_ssh" = "xyes"; then
+ LIBGIT2_GLIB_CFLAGS="${LIBGIT2_GLIB_CFLAGS} -DGIT_SSH=1"
+--
+2.2.1
+