summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-17 05:09:12 +0000
committerSam James <sam@gentoo.org>2022-05-17 05:34:00 +0000
commitb81c5bcf474592fe8ac0cae9979166ce84aa2d76 (patch)
tree844c87a75c7597e4933d9d587b202b3e2f07c02e /dev-libs/libgpg-error
parentapp-crypt/gnupg: [QA] conditionally build tests (diff)
downloadgentoo-b81c5bcf474592fe8ac0cae9979166ce84aa2d76.tar.gz
gentoo-b81c5bcf474592fe8ac0cae9979166ce84aa2d76.tar.bz2
gentoo-b81c5bcf474592fe8ac0cae9979166ce84aa2d76.zip
dev-libs/libgpg-error: [QA] conditionally build tests
It's particularly important for @system and deps-of-@system to not build things unnecessarily given you can't avoid them and it makes builds on slower machines rather painful. But also, it's a waste of resources/time anyway. Do the same dance here as with the other gpg packages. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libgpg-error')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.45.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.45.ebuild b/dev-libs/libgpg-error/libgpg-error-1.45.ebuild
index f79b1022d939..70d0c2d8b3e4 100644
--- a/dev-libs/libgpg-error/libgpg-error-1.45.ebuild
+++ b/dev-libs/libgpg-error/libgpg-error-1.45.ebuild
@@ -12,7 +12,8 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp nls static-libs"
+IUSE="common-lisp nls static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
@@ -52,6 +53,7 @@ multilib_src_configure() {
$(use_enable nls)
# required for sys-power/suspend[crypt], bug 751568
$(use_enable static-libs static)
+ $(use_enable test tests)
--enable-threads
CC_FOR_BUILD="$(tc-getBUILD_CC)"
$("${S}/configure" --help | grep -o -- '--without-.*-prefix')