summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2023-12-27 15:58:30 +0100
committerSam James <sam@gentoo.org>2024-01-01 20:34:25 +0000
commit6bd42bb4ee61ab38d2c9b3673815877802cb2c53 (patch)
tree8f9ae0587026b52d7a9e0ddda09ba23e6ba05d1c /dev-libs/libmateweather
parentmate-extra/mate-media: add myself as a maintainer (diff)
downloadgentoo-6bd42bb4ee61ab38d2c9b3673815877802cb2c53.tar.gz
gentoo-6bd42bb4ee61ab38d2c9b3673815877802cb2c53.tar.bz2
gentoo-6bd42bb4ee61ab38d2c9b3673815877802cb2c53.zip
dev-libs/libmateweather: add 1.26.3
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmateweather')
-rw-r--r--dev-libs/libmateweather/Manifest1
-rw-r--r--dev-libs/libmateweather/libmateweather-1.26.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/Manifest b/dev-libs/libmateweather/Manifest
index d5f8b9980183..4f0c5f4ca886 100644
--- a/dev-libs/libmateweather/Manifest
+++ b/dev-libs/libmateweather/Manifest
@@ -1,3 +1,4 @@
DIST libmateweather-1.26.1.tar.xz 2207404 BLAKE2B 5a5f9804193a50209d3aedc34ba5e605a286445bff624a36db03b94a2c05bd89dbd5c1dc076a694004e90a6c37739ec6a923712504c3ed683480acde0efd6511 SHA512 98cf2363c0bc75341d206d8848484e44665a35e3f01e7f75510555ab341fe06a3c96ea8e1844b17d5da7bc5a172cb18b594c8edfeb28ca8e25a82149ae508748
DIST libmateweather-1.26.2.tar.xz 2205160 BLAKE2B 125efc42a66277222ef5c1538231d01aaf1584ee9314312f98862f84db77b40b4b201bb76f36ec246ffd85863296a013128a0a74090904043a91702d6f91190e SHA512 fd91ae4d89c27163ab7b4c50db944338b584c8769ab6c548bdea14f1d06898e338a35cfa27a0e923a8fc9f05c3620675dd4f706ec47b49423e686e70f97c1384
DIST libmateweather-1.27.1.tar.xz 2203672 BLAKE2B 16a1490eea8d608275b94622ed918332498ebecbe7ddc385095c7b953ed657ead142c4cb0aff8ac8624e6a4ab559e2e54b3e44be10e899889d390023710c0fe8 SHA512 4de78f57768681c77d85dd5cbbea68f4000e37a696b3bd01510a27dceb204b3425db257fe431461eb81fe85395f8c0e072c2821eb6337ef21067734e151a4fcc
+DIST libmateweather-1.26.3.tar.xz 2211104 BLAKE2B b395d05ff462c1d175beba2e143889e771bf98008af724ab648b8aeb3f4760a753d4349d8b66d748242ef2d057811344d8493e12b61d0b2e56e5b3c2067d0eef SHA512 e9285e615e013b7371e738b74647652f5b0abf029f32ba02299e632d882e7d0ff3c41dcac834ddb5b2a4fc93782d67f9764f9abc99a7eb4a26ac07ae12d9cafd
diff --git a/dev-libs/libmateweather/libmateweather-1.26.3.ebuild b/dev-libs/libmateweather/libmateweather-1.26.3.ebuild
new file mode 100644
index 000000000000..9989f90f7bc1
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.26.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.56:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}