summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-14 03:31:48 +0000
committerSam James <sam@gentoo.org>2024-03-14 05:21:25 +0000
commit1cdb73d333da91b0634fcdd1410d87d117e4da2a (patch)
treec6ffc8f57aff93a5d2b281d32cf09dd1293dcd42 /dev-libs/libmcrypt
parentgames-engines/gargoyle: fix VariableOrderWrong (diff)
downloadgentoo-1cdb73d333da91b0634fcdd1410d87d117e4da2a.tar.gz
gentoo-1cdb73d333da91b0634fcdd1410d87d117e4da2a.tar.bz2
gentoo-1cdb73d333da91b0634fcdd1410d87d117e4da2a.zip
dev-libs/libmcrypt: filter LTO, no-SA
Dead upstream, LTO type mismatch. Closes: https://bugs.gentoo.org/924867 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild12
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild10
2 files changed, 19 insertions, 3 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild
index 040220a1d88a..592c4a66ef6e 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Provides an uniform interface to access several encryption algorithms"
HOMEPAGE="https://mcrypt.sourceforge.net"
@@ -36,6 +36,14 @@ src_prepare() {
eautoreconf # update stale autotools
}
+src_configure() {
+ # LTO type mismatch (bug #924867)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
index a09a112ad33b..f376df81912c 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Provides an uniform interface to access several encryption algorithms"
HOMEPAGE="https://mcrypt.sourceforge.net"
@@ -39,6 +39,14 @@ src_prepare() {
eautoreconf # update stale autotools
}
+src_configure() {
+ # LTO type mismatch (bug #924867)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die