summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Whitlock <gentoo@mattwhitlock.name>2024-11-12 12:43:46 -0500
committerSam James <sam@gentoo.org>2024-12-01 11:49:24 +0000
commitcacc52acc43245c2aa286f482e9d79f87ca632e3 (patch)
treed5c896a598b284fe008dde479d7b036de0e8dd68 /dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild
parentdev-libs/libsecp256k1: drop old (diff)
downloadgentoo-cacc52acc43245c2aa286f482e9d79f87ca632e3.tar.gz
gentoo-cacc52acc43245c2aa286f482e9d79f87ca632e3.tar.bz2
gentoo-cacc52acc43245c2aa286f482e9d79f87ca632e3.zip
dev-libs/libsecp256k1: set build-machine toolchain environment
The dev-libs/libsecp256k1 build uses AX_PROG_CC_FOR_BUILD from dev-build/autoconf-archive to detect the toolchain to use for compiling tools to run on the build machine during the build. Portage does not export the expected *_FOR_BUILD environment variables by default, so we have to call tc-export_build_env to set them. Closes: https://bugs.gentoo.org/729888 Signed-off-by: Matt Whitlock <gentoo@mattwhitlock.name> Closes: https://github.com/gentoo/gentoo/pull/39227 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild b/dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild
index 0b1785939856..246a6bac38ed 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-0.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools toolchain-funcs
MyPN=secp256k1
DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
@@ -46,6 +46,10 @@ src_prepare() {
}
src_configure() {
+ # https://bugs.gentoo.org/729888
+ tc-export_build_env BUILD_CC BUILD_CPP
+ export CC_FOR_BUILD="${BUILD_CC}" CPP_FOR_BUILD="${BUILD_CPP}"
+
local myeconfargs=(
--disable-benchmark
$(use_enable experimental)