summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-22 22:05:43 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-22 22:16:13 +0200
commit2f415d49fbebd33f61d763b77810f278563cef19 (patch)
treed0ee66bb1e0cf83bee7e65193dfaa63ac836fbb6 /dev-libs/libugpio/libugpio-0.0.7.ebuild
parentsys-apps/hw-probe: bump to version 1.6_beta2 (diff)
downloadgentoo-2f415d49fbebd33f61d763b77810f278563cef19.tar.gz
gentoo-2f415d49fbebd33f61d763b77810f278563cef19.tar.bz2
gentoo-2f415d49fbebd33f61d763b77810f278563cef19.zip
dev-libs/libugpio: bump to version 0.0.7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/libugpio/libugpio-0.0.7.ebuild')
-rw-r--r--dev-libs/libugpio/libugpio-0.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libugpio/libugpio-0.0.7.ebuild b/dev-libs/libugpio/libugpio-0.0.7.ebuild
new file mode 100644
index 000000000000..9ce29b2cceda
--- /dev/null
+++ b/dev-libs/libugpio/libugpio-0.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Lib for the use of linux kernel's sysfs gpio interface from C programs"
+HOMEPAGE="https://github.com/mhei/libugpio"
+SRC_URI="https://github.com/mhei/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+CONFIG_CHECK="~CONFIG_GPIO_SYSFS"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}