summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libvterm-neovim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libvterm-neovim')
-rw-r--r--dev-libs/libvterm-neovim/Manifest2
-rw-r--r--dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150309.ebuild31
-rw-r--r--dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150621.ebuild31
-rw-r--r--dev-libs/libvterm-neovim/metadata.xml5
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/libvterm-neovim/Manifest b/dev-libs/libvterm-neovim/Manifest
new file mode 100644
index 000000000000..599632e92656
--- /dev/null
+++ b/dev-libs/libvterm-neovim/Manifest
@@ -0,0 +1,2 @@
+DIST libvterm-neovim-0.0_pre20150309.tar.xz 52244 SHA256 eefd3c2383b4378c4eb15b943e3db309577de760a7d06afe1575be40e2427234 SHA512 916bf1806f6c88b64debb19a119010e6e3ef968e289ab921ebf7a5ed2d98f52881379792bc9c8826bba546da0f65cb6154d9743bb89a614ac4e12d24167a1fb4 WHIRLPOOL d25c7049ee1146e8eb4a445fb5369839ffa934db290aa4706c2e118ad09d4cd199a4562f28a3156f4162b0dcd5ee98a53d7130c0310e022bb3c34db431205888
+DIST libvterm-neovim-0.0_pre20150621.tar.xz 52240 SHA256 473e16f72acc001a19c0ed3b1f66798e2cbcedb5c783ddfb7a7ecf95d8245733 SHA512 e6fe678da5498177d7fbd0cd945600b643f7cd76ff9ed00f3ac7923be55793765429a2f2da5fba4055dfaa4b7200c28a021f3672ce7ae16b99e58738e5093fd8 WHIRLPOOL 0d8131c1b7636df41cb83da7378bcba68f158873f5a7bd692317ee66cc84dc9f693913d2d3e5618643436143aeddd73a2b3db809f4c161fd078493706cf725a0
diff --git a/dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150309.ebuild b/dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150309.ebuild
new file mode 100644
index 000000000000..23494da006f7
--- /dev/null
+++ b/dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150309.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool
+ virtual/pkgconfig"
+
+src_compile() {
+ append-cflags -fPIC
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ prune_libtool_files
+
+ dodoc doc/*
+}
diff --git a/dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150621.ebuild b/dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150621.ebuild
new file mode 100644
index 000000000000..23494da006f7
--- /dev/null
+++ b/dev-libs/libvterm-neovim/libvterm-neovim-0.0_pre20150621.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool
+ virtual/pkgconfig"
+
+src_compile() {
+ append-cflags -fPIC
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ prune_libtool_files
+
+ dodoc doc/*
+}
diff --git a/dev-libs/libvterm-neovim/metadata.xml b/dev-libs/libvterm-neovim/metadata.xml
new file mode 100644
index 000000000000..71d319114053
--- /dev/null
+++ b/dev-libs/libvterm-neovim/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>