summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-01 12:42:40 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-01 12:42:40 +0100
commitf465f250a495dfb9b60a51b205ecd27cea7076f1 (patch)
tree9c2e2826a746a4ca80a1b4d7433ded4a6756c459 /dev-libs/opensc
parentdev-libs/opensc: add myself as maintainer (diff)
downloadgentoo-f465f250a495dfb9b60a51b205ecd27cea7076f1.tar.gz
gentoo-f465f250a495dfb9b60a51b205ecd27cea7076f1.tar.bz2
gentoo-f465f250a495dfb9b60a51b205ecd27cea7076f1.zip
dev-libs/opensc: bump to 0.23.0
* add support for dev-libs/openpace Closes: https://github.com/gentoo/gentoo/pull/29334 Closes: https://bugs.gentoo.org/861545 Bug: https://bugs.gentoo.org/892802 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/opensc')
-rw-r--r--dev-libs/opensc/Manifest1
-rw-r--r--dev-libs/opensc/metadata.xml1
-rw-r--r--dev-libs/opensc/opensc-0.23.0.ebuild67
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/opensc/Manifest b/dev-libs/opensc/Manifest
index e2551b04a1a0..118ff09e2ef0 100644
--- a/dev-libs/opensc/Manifest
+++ b/dev-libs/opensc/Manifest
@@ -1 +1,2 @@
DIST opensc-0.22.0.tar.gz 2287020 BLAKE2B 74e4bb6843b640c5a397b820a52180a34159c330f5ecb81af166096f23e2499ef1a4d555b5d71613da57ba121d0f984dcfdc2ba9491f26f826a423725a2321e2 SHA512 70ad5f1219f2ec2a5529a30d8e9955510c77c87d0bc857d5951c7227c75cf9de1c6071f43dd3816a2034123ebd902709793ff776e84d5379fdd54c811ccfaaee
+DIST opensc-0.23.0.tar.gz 2366469 BLAKE2B c0f74379a70347a58be27684ae2cf833e6f35328b566af2c6daa8276174864406fa176acf7ba84931970fe07e3dd8d6eccf7884f079cb0110c4d6ff9a76792dc SHA512 cd102cd64e719c59153960a4921b7525055045f16e6f6ffa8c9def6ce999a9c5098267b41f8753b41107f626bea20c34561002f5d38eddb4ce6b371913a17a1b
diff --git a/dev-libs/opensc/metadata.xml b/dev-libs/opensc/metadata.xml
index bb08161b33aa..58a0aa27c2a1 100644
--- a/dev-libs/opensc/metadata.xml
+++ b/dev-libs/opensc/metadata.xml
@@ -19,6 +19,7 @@
<flag name="ctapi">Use CT-API for accessing Smartcard hardware</flag>
<flag name="notify">Enable notifications</flag>
<flag name="openct">Use <pkg>dev-libs/openct</pkg> (and CT-API) for accessing Smartcard hardware</flag>
+ <flag name="openpace">Use <pkg>dev-libs/openpace</pkg> for EAC version 2 support</flag>
<flag name="pcsc-lite">Use <pkg>sys-apps/pcsc-lite</pkg> (and PC/SC API) for accessing Smartcard hardware</flag>
<flag name="secure-messaging">Enable secure messaging</flag>
</use>
diff --git a/dev-libs/opensc/opensc-0.23.0.ebuild b/dev-libs/opensc/opensc-0.23.0.ebuild
new file mode 100644
index 000000000000..e5fa1b639555
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.23.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 libtool
+
+DESCRIPTION="Libraries and applications to access smartcards"
+HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
+SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ctapi doc openct openpace notify +pcsc-lite readline secure-messaging ssl test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ openpace? ( dev-libs/openpace:= )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ notify? ( dev-libs/glib:2 )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="
+ pcsc-lite? ( !openct !ctapi )
+ openct? ( !pcsc-lite !ctapi )
+ ctapi? ( !pcsc-lite !openct )
+ || ( pcsc-lite openct ctapi )"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --with-completiondir="$(get_bashcompdir)" \
+ --disable-strict \
+ --enable-man \
+ $(use_enable ctapi) \
+ $(use_enable doc) \
+ $(use_enable notify ) \
+ $(use_enable openct) \
+ $(use_enable openpace ) \
+ $(use_enable pcsc-lite pcsc) \
+ $(use_enable readline) \
+ $(use_enable secure-messaging sm) \
+ $(use_enable ssl openssl) \
+ $(use_enable test cmocka) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+
+ insinto /etc/pkcs11/modules/
+ doins "${FILESDIR}"/opensc.module
+
+ find "${ED}" -name '*.la' -delete || die
+}