summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-22 08:32:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-22 08:32:45 +0200
commitacb5831801d188570eb39ac2941d759c5178a7d8 (patch)
treee8448999098939bdad06dbc08643d99a17feaeb0 /dev-libs/quazip
parentdev-libs/quazip: move Qt5Compat dependency (diff)
downloadgentoo-acb5831801d188570eb39ac2941d759c5178a7d8.tar.gz
gentoo-acb5831801d188570eb39ac2941d759c5178a7d8.tar.bz2
gentoo-acb5831801d188570eb39ac2941d759c5178a7d8.zip
dev-libs/quazip: drop 1.3-r1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-libs/quazip')
-rw-r--r--dev-libs/quazip/quazip-1.3-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-libs/quazip/quazip-1.3-r1.ebuild b/dev-libs/quazip/quazip-1.3-r1.ebuild
deleted file mode 100644
index 896e591fba00..000000000000
--- a/dev-libs/quazip/quazip-1.3-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
-HOMEPAGE="https://stachenov.github.io/quazip/"
-SRC_URI="https://github.com/stachenov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-# SONAME of libquazip1-qt5.so, check QUAZIP_LIB_SOVERSION in CMakeLists.txt
-SLOT="0/1.3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- dev-qt/qtcore:5
- sys-libs/zlib[minizip]
-"
-DEPEND="${COMMON_DEPEND}
- test? (
- dev-qt/qtnetwork:5
- dev-qt/qttest:5
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !=dev-libs/quazip-1.1-r0:1
-"
-
-PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DQUAZIP_QT_MAJOR_VERSION=5
- -DBUILD_TESTING=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- use test && cmake_build qztest
-}