summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-24 23:15:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 10:52:37 +0100
commitb4a0add72872dedca2c46b09ef7b8fcfe92925fa (patch)
treea1e7b200e98d631a7321bdfef62ea90b41526e60 /dev-libs/rocm-comgr
parentdev-lang/php: Stabilize 8.2.1 arm64, #890367 (diff)
downloadgentoo-b4a0add72872dedca2c46b09ef7b8fcfe92925fa.tar.gz
gentoo-b4a0add72872dedca2c46b09ef7b8fcfe92925fa.tar.bz2
gentoo-b4a0add72872dedca2c46b09ef7b8fcfe92925fa.zip
dev-libs/rocm-comgr: drop 5.0.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-comgr')
-rw-r--r--dev-libs/rocm-comgr/Manifest1
-rw-r--r--dev-libs/rocm-comgr/files/rocm-comgr-5.0-rocm_path.patch14
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-5.0.2.ebuild50
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-libs/rocm-comgr/Manifest b/dev-libs/rocm-comgr/Manifest
index 037c51bb814e..6675acc0cfeb 100644
--- a/dev-libs/rocm-comgr/Manifest
+++ b/dev-libs/rocm-comgr/Manifest
@@ -1,3 +1,2 @@
-DIST rocm-comgr-5.0.2.tar.gz 117092 BLAKE2B 1ffcb74f9716a8f050d722f569cced66e8e9fa5a23a7156edd1b4dfd7dd7b09a175f3555bbf29ef452d7e4371f65ebe4c6fac30c583468a5563dd59fa92b53e4 SHA512 d2cf4517fc1da1adc367aaa6f53cc099547a931be30cc261d68c8174a5a9ffe3af937fbb298987abbdd7fd5d80364bef6ea9112dcaaf326a410fdd215e568f2f
DIST rocm-comgr-5.1.3.tar.gz 117155 BLAKE2B 40e415c4c7ae3e709dd50981299291f0fc1133f35310b4c86a86847d3bce5fd7685a3f4480f8f156873ca922921c1d4e1cb620fd33bd5cdc87f155af839f2bbe SHA512 5927250f5e03c32b7f270a1dbfe5221d349dfe32aba34143040da53d4e7eb83faa3073a43edabcff13e1fc977bc17088404523f2ab2ea95e207d2c00beb4249b
DIST rocm-comgr-5.3.3.tar.gz 120414 BLAKE2B 29b9d466d74ef94165a2b9bea35eac4616f6b2fc529cdac3c830ee7dc08f219cb9e5d4f081658881c76633f12eaebb74d1a2ea30a76652231b8ee516f9988db1 SHA512 ba7b1ef214e3624168e438ed7fd94291a07508fe89d178c0b158bf22e0998d5a8e4d8f0a7f08f05ac108ef65f725db5764fd66353a85bc25000e572a4fdcb61f
diff --git a/dev-libs/rocm-comgr/files/rocm-comgr-5.0-rocm_path.patch b/dev-libs/rocm-comgr/files/rocm-comgr-5.0-rocm_path.patch
deleted file mode 100644
index 6e908847a54f..000000000000
--- a/dev-libs/rocm-comgr/files/rocm-comgr-5.0-rocm_path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: comgr/src/comgr-env.cpp
-===================================================================
---- comgr.orig/src/comgr-env.cpp
-+++ comgr/src/comgr-env.cpp
-@@ -247,6 +247,9 @@ InstallationDetector *getDetectorImpl()
- if (EnvROCMPath) {
- ROCmInstallPath = EnvROCMPath;
- }
-+ else {
-+ ROCmInstallPath = "@GENTOO_PORTAGE_EPREFIX@/usr";
-+ }
-
- InstallationDetector *Detector;
- if (ROCmInstallPath == "") {
diff --git a/dev-libs/rocm-comgr/rocm-comgr-5.0.2.ebuild b/dev-libs/rocm-comgr/rocm-comgr-5.0.2.ebuild
deleted file mode 100644
index e7ed23e8d3a5..000000000000
--- a/dev-libs/rocm-comgr/rocm-comgr-5.0.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake prefix
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
- inherit git-r3
- S="${WORKDIR}/${P}/lib/comgr"
-else
- SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/ROCm-CompilerSupport-rocm-${PV}/lib/comgr"
- KEYWORDS="~amd64"
-fi
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.5.2-dependencies.patch"
-)
-
-DESCRIPTION="Radeon Open Compute Code Object Manager"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)"
-
-RDEPEND=">=dev-libs/rocm-device-libs-${PV}
- >=sys-devel/llvm-roc-${PV}:="
-DEPEND="${RDEPEND}"
-
-CMAKE_BUILD_TYPE=Release
-
-src_prepare() {
- sed '/sys::path::append(HIPPath/s,"hip","",' -i src/comgr-env.cpp || die
- sed '/sys::path::append(LLVMPath/s,"llvm","lib/llvm/roc",' -i src/comgr-env.cpp || die
- sed '/Args.push_back(HIPIncludePath/,+1d' -i src/comgr-compiler.cpp || die
- sed '/Args.push_back(ROCMIncludePath/,+1d' -i src/comgr-compiler.cpp || die # ROCM and HIPIncludePath is now /usr, which disturb the include order
- eapply $(prefixify_ro "${FILESDIR}"/${PN}-5.0-rocm_path.patch)
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLLD_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/lld"
- -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
- -DClang_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/clang"
- -DCMAKE_STRIP="" # disable stripping defined at lib/comgr/CMakeLists.txt:58
- )
- cmake_src_configure
-}