summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-06-06 18:29:04 +0200
committerCraig Andrews <candrews@gentoo.org>2020-06-06 13:59:58 -0400
commit5bf864eb088a487da87b6dda23ce792dd8def017 (patch)
tree7a480298652090579db0416d6b619198513bc950 /dev-libs/rocr-runtime/files
parentsci-electronics/kicad: Works with py38 (diff)
downloadgentoo-5bf864eb088a487da87b6dda23ce792dd8def017.tar.gz
gentoo-5bf864eb088a487da87b6dda23ce792dd8def017.tar.bz2
gentoo-5bf864eb088a487da87b6dda23ce792dd8def017.zip
dev-libs/rocr-runtime: New ebuild for rocr-runtime 3.5.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://github.com/gentoo/gentoo/pull/16086 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/files')
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-3.5.0-cmake-install-paths.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-3.5.0-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-3.5.0-cmake-install-paths.patch
new file mode 100644
index 000000000000..a98a5f450f0b
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-3.5.0-cmake-install-paths.patch
@@ -0,0 +1,35 @@
+--- a/CMakeLists.txt 2020-06-06 18:15:44.473493765 +0200
++++ b/CMakeLists.txt 2020-06-06 18:25:47.688491464 +0200
+@@ -66,6 +66,7 @@
+
+ list ( APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake_modules" )
+ include ( utils )
++include ( GNUInstallDirs )
+ include ( hsa_common )
+
+ ## Find LibElf
+@@ -185,22 +186,9 @@
+ set_property ( TARGET ${CORE_RUNTIME_TARGET} PROPERTY VERSION "${SO_VERSION_STRING}" )
+ set_property ( TARGET ${CORE_RUNTIME_TARGET} PROPERTY SOVERSION "${SO_MAJOR}" )
+
+-## Create symlinks for legacy packaging and install
+-add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/include/hsa hsa_include_link )
+-if ( ${BUILD_SHARED_LIBS} )
+- add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
+- add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so.${SO_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${SO_MAJOR} )
+-endif()
+-
+ ## Set install information
+-install ( TARGETS ${CORE_RUNTIME_TARGET} DESTINATION hsa/lib COMPONENT binary)
+-install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION hsa/include/hsa COMPONENT binary)
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa COMPONENT dirlink)
+-
+-if ( ${BUILD_SHARED_LIBS} )
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so COMPONENT binary)
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${SO_MAJOR} DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${SO_MAJOR} COMPONENT binary)
+-endif ()
++install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
++install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
+
+ ## Packaging directives
+ set ( CPACK_GENERATOR "DEB;RPM" CACHE STRING "Package types to build")