summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-02-28 23:35:10 -0500
committerCraig Andrews <candrews@gentoo.org>2020-02-28 23:35:43 -0500
commit7fd6a1334be0e50cfe2f992cb8695a239de7e2f6 (patch)
tree016d6b2dc777e5eb6101aa07fa2a71bfcd344656 /dev-libs/rocr-runtime
parentlibretro-core.eclass: Use | instead of : as sed CLFAGS delimiter (diff)
downloadgentoo-7fd6a1334be0e50cfe2f992cb8695a239de7e2f6.tar.gz
gentoo-7fd6a1334be0e50cfe2f992cb8695a239de7e2f6.tar.bz2
gentoo-7fd6a1334be0e50cfe2f992cb8695a239de7e2f6.zip
dev-libs/rocr-runtime: Rename "nonfree" flag to "non-free"
Closes: https://bugs.gentoo.org/706634 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/metadata.xml2
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild4
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/rocr-runtime/metadata.xml b/dev-libs/rocr-runtime/metadata.xml
index 53844ebc13ea..e13e7321708c 100644
--- a/dev-libs/rocr-runtime/metadata.xml
+++ b/dev-libs/rocr-runtime/metadata.xml
@@ -16,6 +16,6 @@
Radeon Open Compute Platform Runtime
</longdescription>
<use>
- <flag name="nonfree">Enables HSA image support using <pkg>dev-libs/hsa-ext-rocr</pkg></flag>
+ <flag name="non-free">Enables HSA image support using <pkg>dev-libs/hsa-ext-rocr</pkg></flag>
</use>
</pkgmetadata>
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild
index 15d5461b129a..d6ba469a09fe 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild
@@ -23,11 +23,11 @@ PATCHES=(
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
-IUSE="nonfree"
+IUSE="non-free"
COMMON_DEPEND="sys-process/numactl"
RDEPEND="${COMMON_DEPEND}
- nonfree? ( dev-libs/hsa-ext-rocr )"
+ non-free? ( dev-libs/hsa-ext-rocr )"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}"
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
index dc116fe5ed4b..29470ab6f6d6 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -20,11 +20,11 @@ HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
-IUSE="nonfree"
+IUSE="non-free"
COMMON_DEPEND="sys-process/numactl"
RDEPEND="${COMMON_DEPEND}
- nonfree? ( dev-libs/hsa-ext-rocr )"
+ non-free? ( dev-libs/hsa-ext-rocr )"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}"