summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-08-19 21:34:43 +0800
committerCraig Andrews <candrews@gentoo.org>2021-08-19 15:46:21 -0400
commita34d121fa34472897d7702341d1f062b1c883358 (patch)
tree7639426addbb3df4f06afa28f9c84c9b49e26bd3 /dev-libs/roct-thunk-interface
parentdev-libs/rocm-device-libs: bump version to 4.3.0 (diff)
downloadgentoo-a34d121fa34472897d7702341d1f062b1c883358.tar.gz
gentoo-a34d121fa34472897d7702341d1f062b1c883358.tar.bz2
gentoo-a34d121fa34472897d7702341d1f062b1c883358.zip
dev-libs/roct-thunk-interface: bump version to 4.3.0
Don't need roct-thunk-interface-4.1.0-append-flags.patch, which is applied in 372b4c17440b76f63b20ed351dda10306e5804c0 from upstream Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22029 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/roct-thunk-interface')
-rw-r--r--dev-libs/roct-thunk-interface/Manifest1
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-4.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/roct-thunk-interface/Manifest b/dev-libs/roct-thunk-interface/Manifest
index 7ba4cb637078..2548cfe9ac8b 100644
--- a/dev-libs/roct-thunk-interface/Manifest
+++ b/dev-libs/roct-thunk-interface/Manifest
@@ -1,3 +1,4 @@
DIST roct-thunk-interface-4.0.0.tar.gz 2694100 BLAKE2B 49ca128902335fc36d44b9e71d444a467bdd0b39ce0b487c70f1f68180fb4b564b10a65e26e41b71d5e66721c3086ec834aee2550246172965f2d611ce9a644a SHA512 cbb45c4372ce2620fce6ccbf94e8e7600256d12acf6721da9d22aeb619cec9d4e4e25354649b83fb322f8d369347c251ebb7242ff8fc3976cc3983de0d8e30a9
DIST roct-thunk-interface-4.1.0.tar.gz 2697077 BLAKE2B 6d5d35c57d73c7d23fe28f438421372c1dcd51b1bcbf8720dfc993ce56a4afb3cd2c5d14185f4424436db4ce6d1d48dd5f802d0fc24ea1dd78ceb5cff7604103 SHA512 adef8c6c8f375d6d402c1066859fdb45f1e938578011fa0008ad242e1365d3672c5cb02a50f98b6f2d760269b4ef46b33a77f237521b76afe42ac883c71ecd86
DIST roct-thunk-interface-4.2.0.tar.gz 3162877 BLAKE2B 48196c2334a5514c17a5b6ca122f0beaf964040f1705bd60532e4379a01d8d6a9b462a7f74916d80841caa9d3a57d5b6e2fb030a9556a1305b879036f9bcec5f SHA512 007cd64e33bada7707f340bffddf6eb9531b0bd5227a5da522c0ff4f0e2efe4a113fc50bf52da19d58fef73008af70a352aad8b41387b327f2ba19b54ede9646
+DIST roct-thunk-interface-4.3.0.tar.gz 3177655 BLAKE2B e3746bb361731484acb5da8c48246fa9ce6cce46919bc771e2670bc4694e09147b51b65274cc58d690e06ce6781aca54d67508625d9ffc1e30f42dbd69adabd5 SHA512 c0515784696464feef906d6ef4446c9bddb77b5abe62e982a7d75331a8b7fb84e94f12ebeaf2e128be28ab8f903bf6894cbf2302aa5ddee23eaf9b2cc807c872
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-4.3.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-4.3.0.ebuild
new file mode 100644
index 000000000000..3cbf10ed4cd6
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-4.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCT-Thunk-Interface-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Thunk Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface"
+CONFIG_CHECK="~HSA_AMD ~HMM_MIRROR ~ZONE_DEVICE ~DRM_AMDGPU ~DRM_AMDGPU_USERPTR"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+src_configure() {
+ local mycmakeargs=(
+ -DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}