summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 01:37:32 +0000
committerSam James <sam@gentoo.org>2022-11-04 02:22:16 +0000
commitc9aa9aa6ed56f63c8b8593792fd76e5cf1c8f349 (patch)
tree740b677128491a3ac03c180383e5110d3e635107 /dev-libs/uulib/uulib-0.5.20-r3.ebuild
parentapp-arch/unzip: build with gnu89 (diff)
downloadgentoo-c9aa9aa6ed56f63c8b8593792fd76e5cf1c8f349.tar.gz
gentoo-c9aa9aa6ed56f63c8b8593792fd76e5cf1c8f349.tar.bz2
gentoo-c9aa9aa6ed56f63c8b8593792fd76e5cf1c8f349.zip
dev-libs/uulib: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/uulib/uulib-0.5.20-r3.ebuild')
-rw-r--r--dev-libs/uulib/uulib-0.5.20-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/uulib/uulib-0.5.20-r3.ebuild b/dev-libs/uulib/uulib-0.5.20-r3.ebuild
new file mode 100644
index 000000000000..d90186cd79ae
--- /dev/null
+++ b/dev-libs/uulib/uulib-0.5.20-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=uudeview-${PV}
+
+DESCRIPTION="Library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libtool.patch # 780018
+ "${FILESDIR}"/${PN}-0.5.20-Fix-Wimplicit-function-declaration-for-strerror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}