summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-10-22 03:16:37 +0000
committerJoonas Niilola <juippis@gentoo.org>2022-11-10 18:15:32 +0200
commit446dba5d542636982c487688af743cd0bf29fada (patch)
treecae22e03eade61e1c6939d6890d602ead2395046 /dev-libs
parentsci-astronomy/siril: add missing BDEPEND for xorg-proto (diff)
downloadgentoo-446dba5d542636982c487688af743cd0bf29fada.tar.gz
gentoo-446dba5d542636982c487688af743cd0bf29fada.tar.bz2
gentoo-446dba5d542636982c487688af743cd0bf29fada.zip
dev-libs/modsecurity: add 3.0.8
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27884 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/modsecurity/Manifest1
-rw-r--r--dev-libs/modsecurity/modsecurity-3.0.8.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/modsecurity/Manifest b/dev-libs/modsecurity/Manifest
index 30ec689bf75f..5c5c37a727c2 100644
--- a/dev-libs/modsecurity/Manifest
+++ b/dev-libs/modsecurity/Manifest
@@ -1 +1,2 @@
DIST modsecurity-v3.0.7.tar.gz 3333372 BLAKE2B f391e2057b95a26a16efaa5f9d86acdd030b2f32d3da3ebac4e5eccdae7c9c6453bdb6b4e2d7f49ce189760d5c5de7d656aa5796fe2723e2e6f5493c93420913 SHA512 d8caf5946b598b16c4481938f22c1116595286811cfdb01d95db95ab061f7045751f2aa98e515df239bceb3f1a6dce2ecd5b24c954bddc27997fa64e9e429730
+DIST modsecurity-v3.0.8.tar.gz 3336288 BLAKE2B de15124362f23c86a6dcee15dd847fcf703a378a57ebd4826a6304fed33b34f4791c7aa80abd42cbe5932063c1ca59f755345e3810dcbc296e2b6a758e0c580b SHA512 8113358548aea19a18de183922e979fd7ce9daad289c6894bda458176f17da63fb45160a2a86d97730c90191c881b232b1c9c6ab9209c3988b4390e49e086117
diff --git a/dev-libs/modsecurity/modsecurity-3.0.8.ebuild b/dev-libs/modsecurity/modsecurity-3.0.8.ebuild
new file mode 100644
index 000000000000..b7405d95da91
--- /dev/null
+++ b/dev-libs/modsecurity/modsecurity-3.0.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Application firewall and intrusion detection"
+HOMEPAGE="https://github.com/SpiderLabs/ModSecurity"
+SRC_URI="https://github.com/SpiderLabs/ModSecurity/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc fuzzyhash geoip geoip2 json lmdb lua pcre2"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RDEPEND="dev-libs/libpcre:=
+ dev-libs/libxml2
+ net-misc/curl
+ fuzzyhash? ( app-crypt/ssdeep )
+ geoip? ( dev-libs/geoip )
+ geoip2? ( dev-libs/libmaxminddb )
+ json? ( dev-libs/yajl )
+ lmdb? ( dev-db/lmdb )
+ lua? ( ${LUA_DEPS} )
+ pcre2? ( dev-libs/libpcre2:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGES README.md modsecurity.conf-recommended unicode.mapping )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with fuzzyhash ssdeep)
+ $(use_with geoip )
+ $(use_with geoip2 maxmind)
+ $(use_with json yajl)
+ $(use_with lmdb)
+ $(use_with lua)
+ $(use_with pcre2)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd doc && doxygen doxygen.cfg || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/html
+ find "${ED}" -name '*.la' -delete || die
+}