summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-09-10 20:08:46 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-09-14 10:38:52 +0300
commit6025273d3ca145017bbc447e768fb821a1cc0161 (patch)
treee6d50b67dc4dbb59533038234b7b111caa33f3c6 /dev-libs
parentapp-editors/vscodium: add a missing dep to 1.60.0 (diff)
downloadgentoo-6025273d3ca145017bbc447e768fb821a1cc0161.tar.gz
gentoo-6025273d3ca145017bbc447e768fb821a1cc0161.tar.bz2
gentoo-6025273d3ca145017bbc447e768fb821a1cc0161.zip
dev-libs/libtpms: Bump to 0.8.6
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.8.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 0751f4736c83..a25838549036 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1 +1,2 @@
DIST libtpms-0.8.5.tar.gz 1255741 BLAKE2B a9960d4f58093f9291ee718c4577138cfd36f637a2911b2bacc3dde68b9def5ab1fd085e38a46b8a57d15f68072e7268a132687f5cc8c593390b1ef986aa0813 SHA512 7f1591b6b655ec99d3737ee41e37e4c0fc05f2e9676463a44c88015b37b2a39291a576e81e394cdf3deac3f1227774c6c60baca445befb24339515773e20b766
+DIST libtpms-0.8.6.tar.gz 1255964 BLAKE2B 44d9b1f78944ede5842b3cbef09900899f53ba3525e63f09de8263b9c1878a889db80eaf3ba35334a2233334bcb4ebd03d2bb841e4184059f9a155ad4a2aa244 SHA512 d57d52d140d582a6a7d2146aa9a10445c5c50807da53b26f6efbb8632ac83afa3c67e1a47ffa6a898a45cbac3aff199fe61947d69bc5af727e9623564bac45d8
diff --git a/dev-libs/libtpms/libtpms-0.8.6.ebuild b/dev-libs/libtpms/libtpms-0.8.6.ebuild
new file mode 100644
index 000000000000..fe5361b4519b
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.8.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-openssl \
+ --with-tpm2
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.8.0; then
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+ fi
+}