summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 20:26:42 +0100
committerSam James <sam@gentoo.org>2023-06-26 20:27:27 +0100
commit6232addfac16312b436f09c3496718b544a16d72 (patch)
tree7f8ee39f220072fddcf999d4a1fecf38607ce07d /dev-libs
parentacct-user.eclass: include exit status in death message (diff)
downloadgentoo-6232addfac16312b436f09c3496718b544a16d72.tar.gz
gentoo-6232addfac16312b436f09c3496718b544a16d72.tar.bz2
gentoo-6232addfac16312b436f09c3496718b544a16d72.zip
dev-libs/crypto++: fix miscompilation
Closes: https://bugs.gentoo.org/864553 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/crypto++/crypto++-8.6.0-r1.ebuild (renamed from dev-libs/crypto++/crypto++-8.6.0.ebuild)12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/crypto++/crypto++-8.6.0.ebuild b/dev-libs/crypto++/crypto++-8.6.0-r1.ebuild
index 0b77d971f0e7..384ec31277f3 100644
--- a/dev-libs/crypto++/crypto++-8.6.0.ebuild
+++ b/dev-libs/crypto++/crypto++-8.6.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/crypto++.asc
-inherit toolchain-funcs verify-sig
+inherit flag-o-matic toolchain-funcs verify-sig
DESCRIPTION="C++ class library of cryptographic schemes"
HOMEPAGE="https://cryptopp.com"
@@ -52,6 +52,14 @@ src_configure() {
export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
export PREFIX="${EPREFIX}/usr"
tc-export AR RANLIB
+
+ # Long history of correctness bugs:
+ # https://github.com/weidai11/cryptopp/issues/1134
+ # https://github.com/weidai11/cryptopp/issues/1141
+ # https://github.com/weidai11/cryptopp/pull/1147
+ append-flags -fno-strict-aliasing
+ filter-lto
+
default
}