summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:31:13 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:49 +0100
commitfe59c742d6a532d3f74ca13cef07d50b435a767b (patch)
tree0e93e8f0dd1927c48dc45d5b6db3d9e04784cd07 /dev-lua/say
parentdev-lua/say: fix lua deps (diff)
downloadgentoo-fe59c742d6a532d3f74ca13cef07d50b435a767b.tar.gz
gentoo-fe59c742d6a532d3f74ca13cef07d50b435a767b.tar.bz2
gentoo-fe59c742d6a532d3f74ca13cef07d50b435a767b.zip
dev-lua/say: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/say')
-rw-r--r--dev-lua/say/say-1.3_p1-r100.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-lua/say/say-1.3_p1-r100.ebuild b/dev-lua/say/say-1.3_p1-r100.ebuild
deleted file mode 100644
index ab75e614cb95..000000000000
--- a/dev-lua/say/say-1.3_p1-r100.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-MY_PV="${PV/_p/-}"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Lua String Hashing/Indexing Library"
-HOMEPAGE="http://olivinelabs.com/busted/"
-SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-
-BDEPEND="
- virtual/pkgconfig
- test? ( >=dev-lua/busted-2.0.0-r100 )
- ${RDEPEND}
-"
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)/say
- doins src/init.lua
-
- einstalldocs
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-}