summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-09 21:41:32 +0000
committerSam James <sam@gentoo.org>2021-06-09 21:41:32 +0000
commit660e8b9da0de345fde4d04c17e13b82d05f42dcf (patch)
tree8f488fbe61990cab19525c3f1428f45d715d891e /dev-ml/camlp4/camlp4-4.10_p1-r1.ebuild
parentdev-lang/ocaml: adjust subslot to be major version (diff)
downloadgentoo-660e8b9da0de345fde4d04c17e13b82d05f42dcf.tar.gz
gentoo-660e8b9da0de345fde4d04c17e13b82d05f42dcf.tar.bz2
gentoo-660e8b9da0de345fde4d04c17e13b82d05f42dcf.zip
dev-ml/camlp4: add subslot dep on OCaml major version
Needs to be exactly aligned with OCaml major version. Closes: https://bugs.gentoo.org/794898 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/camlp4/camlp4-4.10_p1-r1.ebuild')
-rw-r--r--dev-ml/camlp4/camlp4-4.10_p1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/camlp4/camlp4-4.10_p1-r1.ebuild b/dev-ml/camlp4/camlp4-4.10_p1-r1.ebuild
new file mode 100644
index 000000000000..53a6a66d6b41
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.10_p1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/camlp4/camlp4"
+SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:0/4.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+PATCHES=( "${FILESDIR}/reload.patch" )
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}