summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-22 06:52:12 +0000
committerSam James <sam@gentoo.org>2021-01-24 16:06:10 +0000
commit668421835f9e33ca060e424999e1f1cc3fc15ef3 (patch)
treeda3d27a3b8670e55589c698012cb36d0f225ad49 /dev-ml/camlp5/camlp5-8.00.ebuild
parentdev-ml/cppo: bump to 1.6.7 (diff)
downloadgentoo-668421835f9e33ca060e424999e1f1cc3fc15ef3.tar.gz
gentoo-668421835f9e33ca060e424999e1f1cc3fc15ef3.tar.bz2
gentoo-668421835f9e33ca060e424999e1f1cc3fc15ef3.zip
dev-ml/camlp5: bump to 8.00
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/camlp5/camlp5-8.00.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-8.00.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/camlp5/camlp5-8.00.ebuild b/dev-ml/camlp5/camlp5-8.00.ebuild
new file mode 100644
index 000000000000..df181c7416a9
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-8.00.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib vcs-clean
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/camlp5/camlp5/archive/rel${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel${PV}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc +ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ egit_clean
+ default
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile() {
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_test() {
+ emake bootstrap
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ dodoc -r doc/*
+ dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
+}