summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/labltk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/labltk')
-rw-r--r--dev-ml/labltk/Manifest1
-rw-r--r--dev-ml/labltk/files/findlib.patch20
-rw-r--r--dev-ml/labltk/labltk-8.06.0.ebuild44
-rw-r--r--dev-ml/labltk/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ml/labltk/Manifest b/dev-ml/labltk/Manifest
new file mode 100644
index 000000000000..1dc5c02196ec
--- /dev/null
+++ b/dev-ml/labltk/Manifest
@@ -0,0 +1 @@
+DIST labltk-8.06.0.tar.gz 368790 SHA256 71997dbd6c36e4eb064484dc73037d4bd10e465e180fead07a4b193d21af9764 SHA512 c005f8c177bca982a39bfcfd9d77640bedf7e4cc3a6690fc01fa2a8ebedcfb30ad3677501400ae2e0e276eb13fdd565319e23bb02dce84d78257ae7fbe545f47 WHIRLPOOL e231527f1403fbe9aa1102d0a6bc444df0ce5806e64ce8d1323100580767e823922db0713c0d3423f79ff2e82e162673486160953aaea4ff188b5ae666ea4445
diff --git a/dev-ml/labltk/files/findlib.patch b/dev-ml/labltk/files/findlib.patch
new file mode 100644
index 000000000000..9b9a63bdede8
--- /dev/null
+++ b/dev-ml/labltk/files/findlib.patch
@@ -0,0 +1,20 @@
+Index: labltk-8.06.0/lib/Makefile
+===================================================================
+--- labltk-8.06.0.orig/lib/Makefile
++++ labltk-8.06.0/lib/Makefile
+@@ -84,7 +84,7 @@ install-script: $(LIBNAME)
+ install-batch:
+ cp labltk.bat $(INSTALLBINDIR)
+
+-ifeq ($USE_FINDLIB,yes)
++ifeq ($(USE_FINDLIB),yes)
+ install:
+ ocamlfind install labltk -add $(LIBNAME).cma $(LIBNAME)top$(EXE)
+ chmod 755 $(INSTALLDIR)/$(LIBNAME)top$(EXE)
+@@ -114,4 +114,4 @@ installopt:
+ cd $(INSTALLDIR); $(RANLIB) $(LIBNAME).$(A)
+ chmod 644 $(INSTALLDIR)/$(LIBNAME).cmxa
+ chmod 644 $(INSTALLDIR)/$(LIBNAME).$(A)
+-endif
+\ No newline at end of file
++endif
diff --git a/dev-ml/labltk/labltk-8.06.0.ebuild b/dev-ml/labltk/labltk-8.06.0.ebuild
new file mode 100644
index 000000000000..a066cdab69a1
--- /dev/null
+++ b/dev-ml/labltk/labltk-8.06.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
+HOMEPAGE="https://forge.ocamlcore.org/projects/labltk/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1455/${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
+IUSE="+ocamlopt X"
+
+RDEPEND=">=dev-lang/tk-8.0.3
+ >=dev-lang/ocaml-4.02:=[ocamlopt?,X?]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5.5-r1"
+
+src_prepare() {
+ epatch "${FILESDIR}/findlib.patch"
+}
+
+src_configure() {
+ ./configure --use-findlib --verbose $(use X || echo "--tk-no-x11") || die "configure failed!"
+}
+
+src_compile() {
+ emake
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake \
+ INSTALLDIR="${D}$(ocamlc -where)/labltk" \
+ INSTALLBINDIR="${ED}/usr/bin/" \
+ install
+ dodoc Changes README.mlTk
+}
diff --git a/dev-ml/labltk/metadata.xml b/dev-ml/labltk/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/labltk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>