summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Kitover <rkitover@gmail.com>2020-06-11 19:41:10 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-06-24 13:25:33 +0300
commitbd6c21f1a90bec1934f1e7eebfdf94c549e056fe (patch)
tree4b9b812530c0b2eef02657579aaf0f0898543077 /dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2.ebuild
parentdev-ml/stdlib-shims: new package 0.2.0 (diff)
downloadgentoo-bd6c21f1a90bec1934f1e7eebfdf94c549e056fe.tar.gz
gentoo-bd6c21f1a90bec1934f1e7eebfdf94c549e056fe.tar.bz2
gentoo-bd6c21f1a90bec1934f1e7eebfdf94c549e056fe.zip
dev-ml/ocaml-fileutils: add 0.6.2
Using the new dune.eclass. Closes: https://bugs.gentoo.org/704154 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rafael Kitover <rkitover@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2.ebuild')
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2.ebuild
new file mode 100644
index 000000000000..1b299b6fd39d
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-v${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocamlopt"
+
+DEPEND=">=dev-ml/ounit-2.0.0
+ >=dev-ml/stdlib-shims-0.2.0"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-v${PV}"