summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/odns
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/odns')
-rw-r--r--dev-ml/odns/Manifest1
-rw-r--r--dev-ml/odns/files/odns-0.3-parmake.patch16
-rw-r--r--dev-ml/odns/metadata.xml5
-rw-r--r--dev-ml/odns/odns-0.3.ebuild36
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-ml/odns/Manifest b/dev-ml/odns/Manifest
new file mode 100644
index 000000000000..fbf4fb9d451f
--- /dev/null
+++ b/dev-ml/odns/Manifest
@@ -0,0 +1 @@
+DIST odns-0.3.tar.gz 57616 SHA256 368bfbfe240de99f705e162c4382ff51969ff0f69d2c8315f52b813f919f148f SHA512 6d40d7fc882185500aaa58582112abd57faf72ee0a57fabc211ad4bf39739b39cb956e6cb109808e05d767560a942c3300e9ec0e6b28c13cec2a2b4dd0c3bf5d WHIRLPOOL 911f92169ceeb0e35af37585ce2e48e28f12b371784c156c741a3d66fe7d30bf8620bc76d9dce0948c73ec666ccea934a7a91e7cef88e1e9beacaf39f941a6e5
diff --git a/dev-ml/odns/files/odns-0.3-parmake.patch b/dev-ml/odns/files/odns-0.3-parmake.patch
new file mode 100644
index 000000000000..7034abd25cf2
--- /dev/null
+++ b/dev-ml/odns/files/odns-0.3-parmake.patch
@@ -0,0 +1,16 @@
+fix parallel make
+https://bugs.gentoo.org/show_bug.cgi?id=422683
+
+Index: odns-0.3/OCamlMakefile
+===================================================================
+--- odns-0.3.orig/OCamlMakefile
++++ odns-0.3/OCamlMakefile
+@@ -1152,7 +1152,7 @@ $(BCDIDIR)/%.di $(NCDIDIR)/%.di: %.mli
+ $(DOC_DIR)/$(RESULT)/html:
+ mkdir -p $@
+
+-$(DOC_DIR)/$(RESULT)/html/index.html: $(DOC_DIR)/$(RESULT)/html $(DOC_FILES)
++$(DOC_DIR)/$(RESULT)/html/index.html: $(DOC_DIR)/$(RESULT)/html $(DOC_FILES) byte-code-library
+ rm -rf $</*
+ $(QUIET)pp=`sed -n -e '/^#/d' -e 's/(\*pp \([^*]*\) \*)/\1/p;q' $(FIRST_DOC_FILE)`; \
+ if [ -z "$$pp" ]; then \
diff --git a/dev-ml/odns/metadata.xml b/dev-ml/odns/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/odns/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/odns/odns-0.3.ebuild b/dev-ml/odns/odns-0.3.ebuild
new file mode 100644
index 000000000000..b2671781a3e2
--- /dev/null
+++ b/dev-ml/odns/odns-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml library to query DNS servers"
+HOMEPAGE="http://odns.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+CLIBS="" # Workaround for bug #422683
+
+src_prepare() {
+ sed -i -e "s/version=\"0.2\"/version=\"${PV}\"/" META || die
+ epatch "${FILESDIR}/${P}-parmake.patch"
+}
+
+src_compile() {
+ emake -j1 #453434
+}
+
+src_install() {
+ findlib_src_preinst
+ PREFIX="${D}/usr" emake install
+ dodoc AUTHORS README
+}