summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-06 16:20:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-06 16:39:11 +0100
commitb0ee0213b072261f673fc410cdd8d7e2891e2554 (patch)
treed2ae7db0ec135a755d72702ea93c23c5c9c0d457 /dev-ml/ppx_deriving/ppx_deriving-3.0-r1.ebuild
parentwww-servers/nginx: Remove old (diff)
downloadgentoo-b0ee0213b072261f673fc410cdd8d7e2891e2554.tar.gz
gentoo-b0ee0213b072261f673fc410cdd8d7e2891e2554.tar.bz2
gentoo-b0ee0213b072261f673fc410cdd8d7e2891e2554.zip
dev-ml/ppx_deriving: Use opam-installer to install it properly
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-3.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-3.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-3.0-r1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-3.0-r1.ebuild
new file mode 100644
index 000000000000..0099ce56db76
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-3.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/whitequark/ppx_deriving"
+SRC_URI="https://github.com/whitequark/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt test"
+
+DEPEND="dev-ml/ppx_tools:=
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ cp pkg/META.in pkg/META || die
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+ use doc && emake doc
+}
+
+src_test() {
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.byte -- || die
+ if use ocamlopt; then
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.native -- || die
+ fi
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ mv "${ED}/usr/lib/ppx_deriving/ppx_deriving" "${D}/$(ocamlc -where)/ppx_deriving/" || die
+
+ use doc && dohtml api.docdir/*
+
+ dodoc CHANGELOG.md README.md
+}