summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 17:51:22 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commitc180229271611722a7b2b794b25d821ba32b1f98 (patch)
tree5bc94401d0872f0a25eafb388d01513f7a850dd9 /dev-ml/ppx_driver
parentdev-ml/ppx_inline_test: rename ppx executable to avoid conflicts (diff)
downloadgentoo-c180229271611722a7b2b794b25d821ba32b1f98.tar.gz
gentoo-c180229271611722a7b2b794b25d821ba32b1f98.tar.bz2
gentoo-c180229271611722a7b2b794b25d821ba32b1f98.zip
dev-ml/ppx_driver: Use proper install method.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_driver')
-rw-r--r--dev-ml/ppx_driver/ppx_driver-113.24.00.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/ppx_driver/ppx_driver-113.24.00.ebuild b/dev-ml/ppx_driver/ppx_driver-113.24.00.ebuild
index 10b30333f433..66e7dbf02b77 100644
--- a/dev-ml/ppx_driver/ppx_driver-113.24.00.ebuild
+++ b/dev-ml/ppx_driver/ppx_driver-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Feature-full driver for OCaml AST transformers"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -21,7 +20,22 @@ DEPEND="dev-ml/ppx_tools:=
dev-ml/ppx_optcomp:="
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.md )
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}