summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/reactiveData
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/reactiveData')
-rw-r--r--dev-ml/reactiveData/Manifest1
-rw-r--r--dev-ml/reactiveData/metadata.xml8
-rw-r--r--dev-ml/reactiveData/reactiveData-0.1.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/reactiveData/Manifest b/dev-ml/reactiveData/Manifest
new file mode 100644
index 000000000000..c27121febf2e
--- /dev/null
+++ b/dev-ml/reactiveData/Manifest
@@ -0,0 +1 @@
+DIST reactiveData-0.1.tar.gz 17074 SHA256 fc755843daaf3bdf1190d9fbfb63e760d4a0378dea2ae4da7b371b696c4cde14 SHA512 4c1d000d7c8713d365473e924ad22cc285a0d30009e4f3a4c23cb2fed9678209860cbfe9787b4aef24c9d1fe3b8bf2f71609e45bd52abdff5e27adc3afa651c0 WHIRLPOOL 4d9de7aca80f7ed6c1f83247170eec7289da9af2030f462a7a5bfe153d532621c1d1ec38dfd4237654da43694bd5972e55a44224513125117b2e7e24d725a95b
diff --git a/dev-ml/reactiveData/metadata.xml b/dev-ml/reactiveData/metadata.xml
new file mode 100644
index 000000000000..46f20a3fc5e9
--- /dev/null
+++ b/dev-ml/reactiveData/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">hhugo/reactiveData</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/reactiveData/reactiveData-0.1.ebuild b/dev-ml/reactiveData/reactiveData-0.1.ebuild
new file mode 100644
index 000000000000..6c493e0ec7e3
--- /dev/null
+++ b/dev-ml/reactiveData/reactiveData-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Functional reactive programming with incremental changes in data structures"
+HOMEPAGE="https://github.com/hhugo/reactiveData"
+SRC_URI="https://github.com/hhugo/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/react:="
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc README.md
+}