summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-10 14:45:09 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-10 14:45:33 +0200
commitc568c3ce7893f98f4a40949175d053c45c989540 (patch)
tree3645ecb3277bdab357fb4a46c2f94d88cd092d68 /dev-ml/stdio/stdio-0.17.0.ebuild
parentmedia-plugins/vdr-exec: update EAPI 7 -> 8 (diff)
downloadgentoo-c568c3ce7893f98f4a40949175d053c45c989540.tar.gz
gentoo-c568c3ce7893f98f4a40949175d053c45c989540.tar.bz2
gentoo-c568c3ce7893f98f4a40949175d053c45c989540.zip
dev-ml/stdio: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/stdio/stdio-0.17.0.ebuild')
-rw-r--r--dev-ml/stdio/stdio-0.17.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/stdio/stdio-0.17.0.ebuild b/dev-ml/stdio/stdio-0.17.0.ebuild
new file mode 100644
index 000000000000..fafe6ea382a5
--- /dev/null
+++ b/dev-ml/stdio/stdio-0.17.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard IO Library for OCaml"
+HOMEPAGE="https://github.com/janestreet/stdio"
+SRC_URI="https://github.com/janestreet/stdio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"