summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-13 13:15:03 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-13 13:31:19 +0100
commit5785671efdbf5e6b7b0d72bc91dc7dfc6fa106b2 (patch)
treebb20accd43d6c9674067341f4093fd072809cf7d /dev-ml/utop/utop-2.11.0-r1.ebuild
parentdev-ml/lambda-term: fix deps (diff)
downloadgentoo-5785671efdbf5e6b7b0d72bc91dc7dfc6fa106b2.tar.gz
gentoo-5785671efdbf5e6b7b0d72bc91dc7dfc6fa106b2.tar.bz2
gentoo-5785671efdbf5e6b7b0d72bc91dc7dfc6fa106b2.zip
dev-ml/utop: fix deps
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/utop/utop-2.11.0-r1.ebuild')
-rw-r--r--dev-ml/utop/utop-2.11.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/utop/utop-2.11.0-r1.ebuild b/dev-ml/utop/utop-2.11.0-r1.ebuild
new file mode 100644
index 000000000000..0acedbdf1fad
--- /dev/null
+++ b/dev-ml/utop/utop-2.11.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/lambda-term:=
+ dev-ml/logs:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+ dev-ml/zed:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}