summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-06-30 14:47:35 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-06-30 15:13:58 +0200
commit0d09564b338f38419a92c9e5711aaaac0325b269 (patch)
tree5e56c752ce1bdd7f45aa6fb980ee2ce24fcac588 /dev-ml
parentdev-ml/ppx_optcomp: add 0.16.0 (diff)
downloadgentoo-0d09564b338f38419a92c9e5711aaaac0325b269.tar.gz
gentoo-0d09564b338f38419a92c9e5711aaaac0325b269.tar.bz2
gentoo-0d09564b338f38419a92c9e5711aaaac0325b269.zip
dev-ml/time_now: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/time_now/Manifest1
-rw-r--r--dev-ml/time_now/time_now-0.16.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/time_now/Manifest b/dev-ml/time_now/Manifest
index 22463d56e42f..33a333793b0c 100644
--- a/dev-ml/time_now/Manifest
+++ b/dev-ml/time_now/Manifest
@@ -1,2 +1,3 @@
DIST time_now-0.14.0.tar.gz 3666 BLAKE2B 131d4b585ac981fe306ea93f17e332cfabe86a3f8f4564a76e4dc694f9c624e91fe0f0ce26a4ada9fdf0239033fcd29065d76a37e6fb4b79927d116531c04909 SHA512 1b6d1a754e46f1756aa2aad3590e5052999f567630297491d62228ad733b189fbbfc0589b7bafd74e9f77ca0c0421093054e9062d2d5a7d7ed05930be67e9a5f
DIST time_now-0.15.0.tar.gz 3697 BLAKE2B 142e848aa17f3cd14ef9d90a758f21b2ae3881e7e70c1b25fac0980a1d925d41953ded6632423b24e9f124887e71dc07ce1f7c838e45d18724a036bb5cb29473 SHA512 b24bf9fda05cc84c568cc8637771e8774661df738719b4ad30f86ae4a9a984e9f1d344dc58ab6014d37275e99e92bf3b2d34a8c4dfc474faf00c6096f679e371
+DIST time_now-0.16.0.tar.gz 3729 BLAKE2B df7569be37f608bd3f466dc8da96357d42c7bf48f299dd90543222213bdfad7e40f89f368e7dd5e0c2ee53f2b59d43650bd3006ade9bdfde1261cda26d4c306c SHA512 59c380bc89ac5185e344ef051180270bad62ccc7ad60aec4279aba5f71bae8dae6ac29136a6ca85ad7b24e204615fd84cd7db0901b6550de490e8992301c0ac2
diff --git a/dev-ml/time_now/time_now-0.16.0.ebuild b/dev-ml/time_now/time_now-0.16.0.ebuild
new file mode 100644
index 000000000000..18c454106009
--- /dev/null
+++ b/dev-ml/time_now/time_now-0.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Reports the current time"
+HOMEPAGE="https://github.com/janestreet/time_now"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ dev-ml/jane-street-headers:${SLOT}
+ dev-ml/jst-config:${SLOT}
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/ppx_enumerate:=
+ dev-ml/ppx_hash:=
+ dev-ml/ppx_optcomp:${SLOT}
+ dev-ml/stdio:=
+"
+RDEPEND="${DEPEND}"