summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-28 14:01:52 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-28 14:25:05 +0100
commitcbb040c24b09e8f1865b4e4ee9839f9fe34c51f6 (patch)
tree4204d0bb00b0259c068fc75e654eb3a65d6e043f /dev-ml
parentdev-ml/ppx_sexp_conv: bump to 1.15.1 (diff)
downloadgentoo-cbb040c24b09e8f1865b4e4ee9839f9fe34c51f6.tar.gz
gentoo-cbb040c24b09e8f1865b4e4ee9839f9fe34c51f6.tar.bz2
gentoo-cbb040c24b09e8f1865b4e4ee9839f9fe34c51f6.zip
dev-ml/ppx_import: bump to 1.10.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_import/Manifest1
-rw-r--r--dev-ml/ppx_import/ppx_import-1.10.0.ebuild (renamed from dev-ml/ppx_import/ppx_import-1.9.1.ebuild)4
-rw-r--r--dev-ml/ppx_import/ppx_import-1.9.1-r1.ebuild32
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-ml/ppx_import/Manifest b/dev-ml/ppx_import/Manifest
index b0784564811f..a494c3c3778e 100644
--- a/dev-ml/ppx_import/Manifest
+++ b/dev-ml/ppx_import/Manifest
@@ -1 +1,2 @@
+DIST ppx_import-1.10.0.tar.gz 13927 BLAKE2B d036b730dd9c7b5be9fcbf175103ec6f1e2a14111575135a9cfaf935b936165418b34a4b0a37e0d112b7fbc1315526ce21a9db5bebbd99e1898c4a3c245dcf94 SHA512 7d4aeab6512014b5a16fdcc4d26ac29cc22223e18c7ab26e26f9fdd5bcd625c22aa9ff2e6c2106f45408316eaaf755437979961d97139da5973026038c210935
DIST ppx_import-1.9.1.tar.gz 13820 BLAKE2B 295796041ecad89c95bd6a6fe14a9d9bb969f7d984388cca5181c31b8358affeb92a4d200bb9e11449a0216995a8477b809acf251b049e8331eea9e6bb918cb7 SHA512 37bd54bc477b91a3aa4b2433a9817c6d939f1e4a1d950b83b05964d22540296582cec6513a0959fd036f738dbd6ef9df13430183b8bdaa9425c7640a5fddf4b3
diff --git a/dev-ml/ppx_import/ppx_import-1.9.1.ebuild b/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
index 715ab4e1fd80..7e7bd09535f8 100644
--- a/dev-ml/ppx_import/ppx_import-1.9.1.ebuild
+++ b/dev-ml/ppx_import/ppx_import-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
-RDEPEND=">=dev-ml/ppxlib-0.24:="
+RDEPEND=">=dev-ml/ppxlib-0.26:="
DEPEND="${RDEPEND}"
BDEPEND="
test? (
diff --git a/dev-ml/ppx_import/ppx_import-1.9.1-r1.ebuild b/dev-ml/ppx_import/ppx_import-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..c548ecf42c83
--- /dev/null
+++ b/dev-ml/ppx_import/ppx_import-1.9.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A syntax extension for importing declarations from interface files"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_import/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ppxlib-0.24:=
+ <dev-ml/ppxlib-0.26
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ounit2
+ dev-ml/ppx_deriving
+ dev-ml/ppx_sexp_conv
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-dune-ounit2.patch )