summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 22:43:56 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 22:47:00 +1200
commitd8e81594ef661364abea9fe5362e7a74d830f7f4 (patch)
tree5c8ca1747d560c19f878b2193c93d52024edbe6b /dev-perl/Crypt-Eksblowfish
parentgames-action/teeworlds: Up to speed with 2020: cmake.eclass, py38+39 (diff)
downloadgentoo-d8e81594ef661364abea9fe5362e7a74d830f7f4.tar.gz
gentoo-d8e81594ef661364abea9fe5362e7a74d830f7f4.tar.bz2
gentoo-d8e81594ef661364abea9fe5362e7a74d830f7f4.zip
dev-perl/Crypt-Eksblowfish: -r bump for EAPI7 and fixes
- EAPI7 - Parallel Tests - Ensure CFLAGS turn up in build process Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-Eksblowfish')
-rw-r--r--dev-perl/Crypt-Eksblowfish/Crypt-Eksblowfish-0.9.0-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Eksblowfish/Crypt-Eksblowfish-0.9.0-r3.ebuild b/dev-perl/Crypt-Eksblowfish/Crypt-Eksblowfish-0.9.0-r3.ebuild
new file mode 100644
index 000000000000..d66aea6f6c22
--- /dev/null
+++ b/dev-perl/Crypt-Eksblowfish/Crypt-Eksblowfish-0.9.0-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ZEFRAM
+DIST_VERSION=0.009
+inherit perl-module
+
+DESCRIPTION="the Eksblowfish block cipher"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Mix-0.1.0
+ virtual/perl-Exporter
+ >=virtual/perl-MIME-Base64-2.210.0
+ virtual/perl-XSLoader
+ virtual/perl-parent
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ >=virtual/perl-ExtUtils-CBuilder-0.15
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}