summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-26 00:40:40 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-26 00:40:40 +0200
commit347114cbcafdc08378a17f8852b7b6943cb3adcc (patch)
tree38e025f4693433921f368a23c3259d579da68425 /dev-perl/Crypt-SSLeay
parentdev-perl/ORLite: Fix tests (diff)
downloadgentoo-347114cbcafdc08378a17f8852b7b6943cb3adcc.tar.gz
gentoo-347114cbcafdc08378a17f8852b7b6943cb3adcc.tar.bz2
gentoo-347114cbcafdc08378a17f8852b7b6943cb3adcc.zip
dev-perl/Crypt-SSLeay: Drop libressl support
Closes: https://bugs.gentoo.org/624138 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-SSLeay')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r4.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r4.ebuild
new file mode 100644
index 000000000000..994bc9ac8594
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=NANIS
+DIST_VERSION=0.72
+inherit perl-module
+
+DESCRIPTION="OpenSSL support for LWP"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.7c:0=
+ virtual/perl-MIME-Base64
+"
+DEPEND="
+ >=dev-libs/openssl-0.9.7c:0=
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=virtual/perl-ExtUtils-CBuilder-0.280.205
+ virtual/perl-Getopt-Long
+ >=dev-perl/Path-Class-0.260.0
+ >=dev-perl/Try-Tiny-0.190.0
+ test? (
+ >=virtual/perl-Test-Simple-0.190.0
+ )
+"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="
+ dev-perl/libwww-perl
+ >=dev-perl/LWP-Protocol-https-6.20.0
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.720.0-no-ssl3.patch"
+ "${FILESDIR}/${P}-no-dot-inc.patch"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}