summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Redis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Redis')
-rw-r--r--dev-perl/Redis/Manifest2
-rw-r--r--dev-perl/Redis/Redis-1.961.0.ebuild29
-rw-r--r--dev-perl/Redis/Redis-1.976.0.ebuild37
-rw-r--r--dev-perl/Redis/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/Redis/Manifest b/dev-perl/Redis/Manifest
new file mode 100644
index 000000000000..107ae33fe9dd
--- /dev/null
+++ b/dev-perl/Redis/Manifest
@@ -0,0 +1,2 @@
+DIST Redis-1.961.tar.gz 36564 SHA256 782deec57b45d6710dad2cae38299d5079e008a6d60819b62765a81a83262f09 SHA512 8f703bc9e11b4c41df7fb9f686c6bae090d907c026f36bbcead1070be458dd8462e108526db96d1ba28453d30b7b4494e35223d32ae934a678ad571b72d39e78 WHIRLPOOL 85a9c6998b035ea63ef12ceae7e1d8cda5c0a352153377f3abd4e958ec463f04f5a3d674cf504f2e3e36ec6108032fef005e08e7ab2401a0b251a78daa731a72
+DIST Redis-1.976.tar.gz 41598 SHA256 4a6d40ab1e825c1ef9dcb944e6b163d6aeef89a65f08f95643fd90f690ae866a SHA512 776ed8b1ce21dbe354c1ab1aa18a3f029899e18d764dece04d261fae029cebda064f29014391d067531befce585b604dac8b833a51db1497a3cef94212009e3b WHIRLPOOL 76fe513a810cdb35d1268994bf6537f02398a2e564052c501b24895188679420b064e0b96befbd3bfc20eba3592b1ceec07eca6781d21b79491a1887fee9bd75
diff --git a/dev-perl/Redis/Redis-1.961.0.ebuild b/dev-perl/Redis/Redis-1.961.0.ebuild
new file mode 100644
index 000000000000..e8ff4190f606
--- /dev/null
+++ b/dev-perl/Redis/Redis-1.961.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MELO
+MODULE_VERSION=1.961
+inherit perl-module
+
+DESCRIPTION="Perl binding for the Redis database"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Digest-SHA
+ dev-perl/IO-String
+ virtual/perl-IPC-Cmd
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Redis/Redis-1.976.0.ebuild b/dev-perl/Redis/Redis-1.976.0.ebuild
new file mode 100644
index 000000000000..6551f7b20192
--- /dev/null
+++ b/dev-perl/Redis/Redis-1.976.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DAMS
+MODULE_VERSION=1.976
+inherit perl-module
+
+DESCRIPTION="Perl binding for Redis database"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/IO-Socket-Timeout-0.220.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.36.0
+ test? (
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/IO-String
+ virtual/perl-IPC-Cmd
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-SharedFork
+ >=dev-perl/Test-TCP-1.190.0
+ )
+"
+
+mytargets="install"
diff --git a/dev-perl/Redis/metadata.xml b/dev-perl/Redis/metadata.xml
new file mode 100644
index 000000000000..36ee0f08c67c
--- /dev/null
+++ b/dev-perl/Redis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+</pkgmetadata>