summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-02 20:12:15 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-02 20:12:15 +0200
commit955de705dce88f2ebb8fd33f85422e4b952db3aa (patch)
tree9dc8aaa596944b193c22a76640442b711caddc1a /dev-perl/Search-Xapian
parentdev-perl/Search-Xapian: Disable tests; missing dependencies (diff)
downloadgentoo-955de705dce88f2ebb8fd33f85422e4b952db3aa.tar.gz
gentoo-955de705dce88f2ebb8fd33f85422e4b952db3aa.tar.bz2
gentoo-955de705dce88f2ebb8fd33f85422e4b952db3aa.zip
dev-perl/Search-Xapian: Revision bump, EAPI=6 and added missing test deps
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Search-Xapian')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.23.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.23.0-r1.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.23.0-r1.ebuild
new file mode 100644
index 000000000000..4b1dc6b63874
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.23.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-libs/xapian:0/1.2.22
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Devel-Leak )
+"
+
+DIST_TEST=do
+# parallel fails sometimes...
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}