summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-01-05 13:44:15 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-01-05 13:44:33 +0100
commit1cf4c019b5c490d523a9965de1b22a88e2800af2 (patch)
treea2fa5cf76a67b2e4795152bdba04e01ac9be4771 /dev-perl/Test-MockModule/Test-MockModule-0.50.0-r2.ebuild
parentdev-java/jfreesvg: Use java-pkg_clean instead of find. (diff)
downloadgentoo-1cf4c019b5c490d523a9965de1b22a88e2800af2.tar.gz
gentoo-1cf4c019b5c490d523a9965de1b22a88e2800af2.tar.bz2
gentoo-1cf4c019b5c490d523a9965de1b22a88e2800af2.zip
dev-perl/Test-MockModule: Add missing dependencies, straight to stable
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-perl/Test-MockModule/Test-MockModule-0.50.0-r2.ebuild')
-rw-r--r--dev-perl/Test-MockModule/Test-MockModule-0.50.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Test-MockModule/Test-MockModule-0.50.0-r2.ebuild b/dev-perl/Test-MockModule/Test-MockModule-0.50.0-r2.ebuild
new file mode 100644
index 000000000000..b9d1a6b26605
--- /dev/null
+++ b/dev-perl/Test-MockModule/Test-MockModule-0.50.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_VERSION=0.05
+MODULE_AUTHOR="SIMONFLK"
+inherit perl-module
+
+DESCRIPTION="Override subroutines in a module for unit testing"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/CGI
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"