summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 20:06:55 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 20:07:32 +1300
commitdbd810acd7ca84e9359926edc54adf8172e89f12 (patch)
tree3592ebd2a474cc9890fc1f1e8789d8f5fa78e3e8 /dev-perl/XML-SAX/files
parentapp-portage/g-sorcery-0.2.1-r1: added ~mips, bug 524040 (diff)
downloadgentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.tar.gz
gentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.tar.bz2
gentoo-dbd810acd7ca84e9359926edc54adf8172e89f12.zip
dev-perl/XML-SAX: Bump to version 1.0.0
- EAPI6 - Enable parallel tests - Rework auto-ini-generation removal logic as a patch - Cease using encodings.patch which now appears of little value ( was included as part of #127735 but the fix that fixed that issue is long upstreamed and tests indicate it no longer relevant ) Upstream: - Build order fixes for vanilla installs Bug: https://bugs.gentoo.org/127735 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-SAX/files')
-rw-r--r--dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch b/dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch
new file mode 100644
index 000000000000..75ec799e17e8
--- /dev/null
+++ b/dev-perl/XML-SAX/files/XML-SAX-1.00-noautoini.patch
@@ -0,0 +1,63 @@
+From 69984a8dbd2553d5a3c504c0f945b955d243380f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 28 Mar 2018 19:48:34 +1300
+Subject: Remove all of the automatic INI generation code.
+
+As this will be handled by Gentoo outside the install phase anyway.
+
+Bug: https://bugs.gentoo.org/168988
+---
+ Makefile.PL | 40 ----------------------------------------
+ 1 file changed, 40 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index b0b09c7..78c5f3b 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -12,43 +12,3 @@ WriteMakefile(
+ 'XML::NamespaceSupport' => 0.03,
+ },
+ );
+-
+-sub MY::install {
+- package MY;
+- my $script = shift->SUPER::install(@_);
+-
+- # Only modify existing ParserDetails.ini if user agrees
+-
+- my $write_ini_ok = 0;
+-
+- eval { require XML::SAX };
+- if ($@) {
+- $write_ini_ok = 1;
+- }
+- else {
+- my $dir = File::Basename::dirname($INC{'XML/SAX.pm'});
+- if (-e File::Spec->catfile($dir, 'SAX', 'ParserDetails.ini')) {
+- $write_ini_ok =
+- ExtUtils::MakeMaker::prompt(
+- "Do you want XML::SAX to alter ParserDetails.ini?", "Y"
+- ) =~ /^y/i;
+- }
+- else {
+- $write_ini_ok = 1;
+- }
+- }
+-
+- if ($write_ini_ok) {
+- $script =~ s/install :: (.*)$/install :: $1 install_sax_pureperl/m;
+- $script .= <<"INSTALL";
+-
+-install_sax_pureperl : pure_install
+-\t\@\$(PERL) -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()"
+-
+-INSTALL
+-
+- }
+-
+- return $script;
+-}
+-
+--
+2.16.2
+