summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-20 04:15:44 +0000
committerSam James <sam@gentoo.org>2021-12-20 04:17:34 +0000
commit9872461571b92698910b2cdb83a1f7e0dadf0014 (patch)
tree0929cdf6650a7b0a67b13e4642be4c723966a68a /dev-perl/libwww-perl
parentdev-libs/tree-sitter-meta: new grammars + fix circular dep (diff)
downloadgentoo-9872461571b92698910b2cdb83a1f7e0dadf0014.tar.gz
gentoo-9872461571b92698910b2cdb83a1f7e0dadf0014.tar.bz2
gentoo-9872461571b92698910b2cdb83a1f7e0dadf0014.zip
dev-perl/libwww-perl: fix VariableScope
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.600.0-r1.ebuild (renamed from dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild)10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.600.0-r1.ebuild
index 703519c8526d..97c54ca9012c 100644
--- a/dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild
+++ b/dev-perl/libwww-perl/libwww-perl-6.600.0-r1.ebuild
@@ -54,9 +54,7 @@ PDEPEND="
)
"
-src_install() {
- perl-module_src_install
-
+pkg_postinst() {
# Perform a check to see if the live filesystem is case-INsensitive
# or not. If it is, the symlinks GET, POST and in particular HEAD
# will collide with e.g. head from coreutils. While under Linux
@@ -67,8 +65,8 @@ src_install() {
# bash should always be there, if we can find it in capitals, we're
# on a case-INsensitive filesystem.
if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
- dosym lwp-request /usr/bin/GET
- dosym lwp-request /usr/bin/POST
- dosym lwp-request /usr/bin/HEAD
+ ln -s lwp-request "${EROOT}"/usr/bin/GET
+ ln -s lwp-request "${EROOT}"/usr/bin/POST
+ ln -s lwp-request "${EROOT}"/usr/bin/HEAD
fi
}