summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-12-18 14:27:27 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 14:27:42 -0500
commite8b29eb86eea183639c9ed2ce5c0010d99faa93f (patch)
tree4dfa338c88d99d18bc51bd57240f0d169ce384d7 /dev-php/libchart/libchart-1.3.ebuild
parentsys-boot/unetbootin: Old. (diff)
downloadgentoo-e8b29eb86eea183639c9ed2ce5c0010d99faa93f.tar.gz
gentoo-e8b29eb86eea183639c9ed2ce5c0010d99faa93f.tar.bz2
gentoo-e8b29eb86eea183639c9ed2ce5c0010d99faa93f.zip
dev-php/libchart: replace snapshot with final v1.3 release.
We temporarily had a snapshot in the tree as a precaution against the demise of Google Code. Now that the final v1.3 release has been added to Github, we use that instead. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/libchart/libchart-1.3.ebuild')
-rw-r--r--dev-php/libchart/libchart-1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/libchart/libchart-1.3.ebuild b/dev-php/libchart/libchart-1.3.ebuild
new file mode 100644
index 000000000000..ff816e5809e0
--- /dev/null
+++ b/dev-php/libchart/libchart-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Easy-to-use chart creation library for PHP"
+HOMEPAGE="http://naku.dohcrew.com/libchart https://github.com/naku/libchart"
+SRC_URI="https://github.com/naku/${PN}/releases/download/release/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php:*[gd,truetype]"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dodoc "${PN}"/{ChangeLog,README}
+
+ if use examples ; then
+ # PHP won't run a compressed example...
+ docompress -x "/usr/share/doc/${PF}/demo"
+ dodoc -r demo/
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins -r "${PN}"/{classes,fonts,images}
+}