summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-15 09:52:25 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-15 09:52:25 +0200
commitc69a0af0cf446a84f0f7f4e40f766edb905c0412 (patch)
treed0ff169e86c6bed1e57b6c8d3fb3108673086848 /dev-php/pecl-http
parentdev-lang/php: drop 7.4.33-r4, 7.4.33-r5, 7.4.33-r6 (diff)
downloadgentoo-c69a0af0cf446a84f0f7f4e40f766edb905c0412.tar.gz
gentoo-c69a0af0cf446a84f0f7f4e40f766edb905c0412.tar.bz2
gentoo-c69a0af0cf446a84f0f7f4e40f766edb905c0412.zip
*/*: remove USE=php_targets_php7-4
Closes: https://github.com/gentoo/gentoo/pull/32762 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-php/pecl-http')
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.2.ebuild19
1 files changed, 3 insertions, 16 deletions
diff --git a/dev-php/pecl-http/pecl-http-4.2.2.ebuild b/dev-php/pecl-http/pecl-http-4.2.2.ebuild
index 6f8fca855057..4b7e320a307b 100644
--- a/dev-php/pecl-http/pecl-http-4.2.2.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.2.2.ebuild
@@ -9,12 +9,10 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"
-USE_PHP="php7-4 php8-0 php8-1"
+USE_PHP="php8-0 php8-1"
inherit php-ext-pecl-r3
-USE_PHP="php8-0 php8-1"
-
KEYWORDS="amd64 x86"
DESCRIPTION="Extended HTTP Support for PHP"
@@ -33,19 +31,14 @@ COMMON_DEPEND="app-arch/brotli:=
DEPEND="
php_targets_php8-0? ( ${COMMON_DEPEND} dev-lang/php:8.0[session(-),iconv(-)] )
php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )"
-RDEPEND="${DEPEND}
- php_targets_php7-4? ( dev-php/pecl-http:7[php_targets_php7-4(-)] )"
+RDEPEND="${DEPEND}"
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
--without-http-libidn-dir --without-http-libicu-dir
--without-http-libidnkit2-dir --without-http-libidnkit-dir )
src_prepare() {
- if use php_targets_php8-0 || use php_targets_php8-1 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
+ php-ext-source-r3_src_prepare
# Respect LDFLAGS, bug 727134
export EXTRA_LDFLAGS="${LDFLAGS}"
@@ -71,9 +64,3 @@ src_test() {
rm modules/raphf.so || die
done
}
-
-src_install() {
- if use php_targets_php8-0 || use php_targets_php8-1 ; then
- php-ext-pecl-r3_src_install
- fi
-}